Unable to save test case


#1

Hi guys,

I have encounter a problem in version after 5.10.x. When I’m trying to change a default value of variable in a test case, the new value does not reflect after i press enter, but when i click in the default value, it reflects. Nor matter how many time i edit the default value in a variable, it still the same. Furthermore, when I’m trying to save the test case, it prompts me error unable to save part. Did you guys encounter this issue?


#2

Are you still having the issue? Can you send me the log file?


#3

@Alice
yes…i cant save my test case after i change the variable default value.
How could i get the log file for you?log.txt (252.3 KB)


#4

Hi Alan_Chan1

Have you checked if you have full access (read, write, modify, etc.) to the Katalon executable folder, specially to the following path:

…\configuration\resources\template\editor\codemirror\


#5

I can reproduce the same error.
Just downloaded/extracted a fresh Katalon studio 5.10.1. Create a new project, add new test cast, then add new variable (no other actions)

The whole test case can not be saved unless I delete the variable.
And the Variables(script mode) view seems strange.
Capture1


#6

Hi

Has there been any update here? Im experiencing the same after installing 5.10.1 (linux amd64)

Update, just installed 5.9.0 (linux amd64) same issue.

I can confirm all permissions to the folder and project files are owned and read/writable.

Thanks,


#7

I’m fairly new to variables and Katalon in general but I’m hitting this issue. Can’t create my own variables. I’m able to add variables in the script section of the test case, but after saving they won’t appear in my list of variables. Which makes me think I’m doing something wrong…which is likely.


#8

I’m experiencing the ‘Unable to save part.’ issue/message as well. Using a fairly fresh 5.10.1 build.


#9

Hi @Jeff_Sharp, @mr_a_hunt , @Tom6

This issue seems to be troubling yet we can’t reproduce it. Could you guys share with us detail steps to reproduce it ? Maybe there may be some hidden commonalities that may help us. Please look at this post.

https://forum.katalon.com/t/tip-my-test-is-broken-nothing-works-please-help-me/12919/14

Have a nice day !


#10

Same issue. Brand New Katalon Install. After ignoring the changes and re applying the changes to the groovy file, we were able to save again.


#11

This issue happens regularly when i’m scripting test cases. It just happens randomly since i have upgraded to the version 5.10.x onward. Temporary solution i have to delete the whole katalon studio and download a new one to launch my project.


#12

Im also facing the same issue.is there a solution available for this issue?


#13

I’m no longer having this issue. I didn’t change anything so I’m not sure why it’s no longer occurring, but it hasn’t happened for over about a week now.


#14

Hi, we are getting this issue as well. It happens when changing value of variable on “Variable” tab in Test Case.
Workaround is to switch to tab “Manual”, click “Save All” button and then you can work again.
It’s really annoying and would be great to fix this. I can also confirm that this issue occurs on random basis, but quite often.


#15

I am facing this issue invariably.
Makes the tool look useless because it won’t let me save and all my progress was lost.


#16

Hi Team,

Unable to open browser on Linux using KATALON and also unable to save new script.

Please suggest resolution.

Thanks


#17

@Ajeet_Kumar_Yadawa,which version of Katalon are you using? Please also send us the log file when you encounter any of the above errors.
Regards.


#18

I have similar outstanding issue:


#19

i found a temporary work solution, when you face the problem unable to save part again, just rename your test case. It might retains your edit part.