SOAP API test proxy issue


#1

Hello,

I have the issue with katalon so that when I am connected to the company’s VPN, I cannot make any request, the app just throws “java.net.ConnectException: Connection timed out: connect” error when I try load data from WSDL. However, when I disconnect from VPN, everything works fine. The interesting part is that I’ve already set up a proxy in Katalon preferences and UI tests work fine.

Have anyone faced this issue?


#2

Are you (is your PC) inside the company’s VPN (=working in the office)?

Or are you (is your PC) outside the VPN? (=at your home and connect to VPN via Internet)?

When you are connected to the company’s VPN, does UI tests work fine?

When you are connected to the company’s VPN, does your SOAP API test fail?


#3

Are you (is your PC) inside the company’s VPN (=working in the office)?

Or are you (is your PC) outside the VPN? (=at your home and connect to VPN via Internet)?

I am working outside of the office and connect to VPN via internet.

When you are connected to the company’s VPN, does UI tests work fine?

Yes

When you are connected to the company’s VPN, does your SOAP API test fail?

Correct


#4

What happens if you are connected to the company’s VPN and you try to GET the URL of your SOAP API test? Do you see valid response on browser? or do you encounter any connection failure?


#5

What happens if you are connected to the company’s VPN and you try to GET the URL of your SOAP API test? Do you see valid response on browser? or do you encounter any connection failure?

When I open the link in browser, I am able to see the response.

However, when I do request through katalon, I am getting the following error


#6

In the screenshot I found a URL to WSDL:
http://webservices.oorsprong.org/websamples.countryinfo/CountryInfoService.wso?WSDL

When you are NOT connected to the company’s VPN, can you get this URL of WSDL with browser?

When you are connected to the company’s VPN, can you get this URL of WSDL with browser? Do you see valid response?


#7

When you are connected to the company’s VPN, can you get this URL of WSDL with browser? Do you see valid response?

Yes, I can get it and I can see the valid response.

When you are NOT connected to the company’s VPN, can you get this URL of WSDL with browser?

Same, yes, I can see it.

Moreover, when I am using SOAP UI, I can get the response when I am connected to VPN


#8

I do not see what you mean by this.


#9

I do not see what you mean by this.

It’s another app for API testing. https://www.soapui.org/

I assume, I somehow can handle proxy settings in http header but I don’t know how.


#10

Let me clarify,

do you use Windows? do you follow the Windows setup method to connect your PC to the VPN, something like this?
https://www.digitalcitizen.life/how-create-and-use-vpn-connections-windows-7


#11

do you use Windows? do you follow the following method to connect your PC to the VPN?
https://www.digitalcitizen.life/how-create-and-use-vpn-connections-windows-7

I do use Windows. I am using cisco anyconnect, which was configured for me.


#12

Have you every tried to run your SOAP API test inside your company’s intranet? I mean, not via VPN.


#13

Have you every tried to run your SOAP API test inside your company’s intranet? I mean, not via VPN.

No, I haven’t and I am not sure when I’ll be in the office next time.


#14

Please check it.

I think you should make it clear if VPN connection is significant for your incident or not.


#15

As I said, I don’t know when I’ll be in the office next time. Therefore, I need it to be worked through the vpn.


#16

@devalex88,

Please participate with this issue.


#17

Please try disabling BrowserMob proxy and let me know the result. This proxy is used for recording requests.


#18

Disabled, didn’t help.


#19

@devalex88

Are there any other possible solutions?


#20

I have the same problem. Party I could solve it by manually setting the proxy. That works for rest. But for soap i get the same error. When I set the proxy in soapui it works as expected… Somehow it does not use the proxy in the settings. Is it possible to override it via a custom keyword