Katalon doesn't work with VPN's At all

I have a VPN, private internet access, one of the most popular out there. If I connect to the VPN, katalon can’t update the web drivers for the browsers, and when I try to run any test, it will never open the browser, it’ll just sit there doing nothing. If I disconnect from the VPN, Katalon starts working again. The proxy settings don’t do anything, because I don’t use proxies, I use a VPN.

For whatever reason, when you connect to a VPN, the entire computer will be able to connect to the internet, but Katalon Studio can’t locate the browser. If you disconnect from the VPN, it starts working again.

The browser and all other features of windows work absolutely fine behind the VPN, it’s just Katalon that can’t see the internet behind a VPN, for whatever reason.

This is the newest version I just downloaded it an hour ago but unfortunately that’s a deal breaker for me.

Me too, I have a number of them - part of my job and personal choice. Katalon works fine here.

Does Katalon write anything to the log file?

Perhaps if you’re paying for the VPN, you can contact them and ask for support?

I have been working from home for the last 10 months using VPN and KS. I would review your VPN settings with your company’s Support/Helpdesk.

Also check with your company’s security department (or Network Support) about it too. Do you perhaps have two logins for the difference times you login? They sometimes don’t realize what they do for how it affects you working remotely.

To answer your question, and it does this with all browsers. It loads the webdriver, say chromedriver, and then it gets to the point where it tries to open the browser and that’s where it errors out.

With the VPN signed in, it cannot open or find any web browser, if I disconnect, it’ll work fine. I’m wondering if Katalon only goes off the primary network adapter in windows and won’t get internet from the network adapter my VPN makes.

No I don’t have a company security department. I’m using a VPN i pay $4.99 a month for on the internet called private internet access. It doesn’t block anything, in fact I can set it so that chromedrive and katalon both bypass the VPN and it still doesn’t work, it’s not my VPN, it’s Katalon. I also learned enough about Katalon to make it load the chromedriver with a batch file so I could put a command line in it to allow all connections rather than just the local IP, I thought that may be the problem, but it’s not.

I think it’s because the private internet access adds another network adapter in windows, and that’s where the internet is served from. I think Katalon is bound to the primary network adapter, and there is no setting anywhere to change it. I don’t know, just a suspicion.

I do know that every single thing possible works with my VPN other than Katalon Studio
and I know that disconnecting from the VPN makes Katalon work.

I don’t know either, but that sounds like the Java runtime at fault.

You may have already tried this, but it’s worth a shot:

  1. Disconnect from the vpn.

  2. Close Katalon.

  3. Connect the vpn.
     At this point, you could try resetting the adapter/nic (disable, enable).

  4. Open Katalon.

If Katalon still doesn’t work, I’d say your suspicion is correct.