Katalon auto logs out

How would your work be affected if this issue has not been resolved?

I can continue my job, but my performance is lower than expected

Operating System

Windows 10

Katalon Studio Version


Expected Behavior:

My session isn’t finished automatically.

Actual Behavior:

My session is finished after a while, after this message is displayed:

I’ve read in documentation: Configure idle timeout But that option is not enabled in my project:

So I don’t know how to solve it. It’s quite annoying because it takes up to much time reloading the project.

I have the exact same issue. Worked fine with previous versions of KS.

  • Log in into your Katalon TestOps account
  • From the top right wheel, select any of those, e.g license Management so you are redirected to the Admin page
  • You will find the needed setting at the bottom of the left list
    See pic:

We both have that off. It did not happen a 2nd time, so maybe something to do with first time running new version?

i have no idea about it, i am not using such. if happens again, feel free to open a bug, my two cents are on some temporary ‘transitioning’ issues between katalon studio api and testops api.

I spoke to soon, it popped up again. I will open a bug.

from katalon release notes:

  • [License Activation] Changed the Katalon license server to https://admin.katalon.com/. For authentication, Katalon Studio and Katalon Runtime Engine call this new server URL.

not sure if related, but looks like there are some movements ‘under-the-hood’ … feel free to rise bug reports

Yep, been trying to submit a ticket but when I click submit it just reloads the screen. No messages or anything saying what is wrong. Even tried various browsers. “https://support.katalon.com/hc/en-us/requests”.

Thanks, @bionel. I followed your instructions and here is what I saw:


My uderstaning is this settings should’ve prevented us from that ugly behaviour Katalon has decided to introduce but it does NOT. It looks like KSE keeps auto logging out even when Idle timeout is disabled.

In my case, it’s hapened multiple times alredy even though it’s been off.

well, i only showed to you guys where the settings is.
if it is not working feel free to open bug’s.
i am not actually using it

Hi everyone,

Noted and will get back to you ASAP. Kindly submit a ticket to our customer support team on this matter https://support.katalon.com/hc/en-us/articles/4406228320409-How-to-contact-the-Katalon-Customer-Support-team-.

@chrisstu I have tried for days to submit a ticket. When I click “Submit” it just reloads the screen with no messages indicating an error. Your ticketing system is broken somewhere.

1 Like

@chrisstu, I mentioned above that submitting a ticket is not working. I have tried many times, and have even rebooted a couple of times between attempts. No error message is given. When I click on “Submit” it just reloads the screen. All the fields are filled, and no red error prompt pops up. I am using my official licensed account @canada.ca, and not my community account.

I have even tracked submission using Chrome dev tools, but cannot see why it is not working. Please open a ticket for me against my @canada.ca account.

Hi Danpo,

Thank you for your comment, I have sent to the support team and they are taking actions.
For this topic, however, this message isn’t related to Idle Timeout feature. It’s our session termination mechanism, kindly recheck your license on this.

Please refer to https://docs.katalon.com/katalon-studio/docs/session-termination.html for common causes.

Hi Danpo,

Please try to empty the execution log and error log fields then attach those as attachments to see how it works for you.

All licenses are fine, we have 6 node locked. I have not had this problem until the last two releases.

1 Like

I feel this is something related to the way Katalon verifies licenses. I use a VPN to work and I need a proxy to verify the license. If I have Katalon opened while I’m out of VPN, the session is ended. It’s annoying since I don’t need the VPN if I just want to check some code.

1 Like

This is the time when you have to start to study basic networking (routing and so on).
For any unicorn there is a solution, but your case it is not a common one.
Kindly work on this with your IT team.