Error reloading plugins


#1

my company bought the Jira integration and when I go to plugin store/reload plugins I get the following error:

anyone know what this is?

Error reloading plugins
Unexpected error occurs during executing reload plugins due to invalid API Key


#2

Hi @ddicocco,

Please kindly check whether your Katalon Studio account has been invited to use the plugin.

You will receive an invitation email with the link to the My Plugins page.

To start using the plugin, click Activate, then reload in Katalon Studio.

Thank you.

Cheers,
Katalon Store Team


#3

If there still be the problem, try with this:

  • Go to config⁩/⁨.metadata⁩/.plugins⁩/⁨org.eclipse.core.runtime⁩/.settings
  • Delete com.kms.katalon.prefs file and login again
    Hope this helps.

Cheers,
Katalon Store Team


#4

i was able to reload the plugin. i needed to upgrade my katalon studio. the problem i am having now is that when i try to connect in project/settings it tells me that the username and pwd is wrong when i know i have all the information in there correctly.


#5

@huynguyen Can you please take a look? Thanks


#6

@ddicocco,
what do you try to connect in project/settings? Can you provide any screenshots?


#7

so here is the deal. when I try to go through project settings it says that the account is not valid. please check username and password.
BUT when I click on the bug icon in a test run report it seems to be using all of the info from project settings to take me directly to Jira.

see attached

image


#8

Please try removing the /secure part in the URL.

@duyluong


#9

that didn’t work either. I have no idea what is going on because if I try to access Jira from the report using the bug icon it takes me directly to Jira where I can enter a bug. I have even watched it use that username and pwd from my settings to bring up the Jira page.


#10

Sorry for the issue. We’ve updated the docs for Jira Cloud integration. Please reload the plugin to make sure it is the latest version, and follow instructions here:

  • Server URL must be in the form https://<site_name>.atlassian.net.
  • Use a Atlassian Cloud’s API token for Password. See instructions here.

#11

@Katalon_Store
I’ve deleted the com.kms.katalon.prefs file, and I’m still not able to get the plugins that were assigned to my account. When I click on Reload plugin, I only get information that No plugins found. Please go to […]. What else should I do yo get the plugins?

Log:

!ENTRY org.eclipse.e4.ui.workbench 1 0 2019-05-16 08:43:16.605
!MESSAGE Credentials found. Reloading plugins.

!ENTRY org.eclipse.e4.ui.workbench 1 0 2019-05-16 08:43:17.693
!MESSAGE Latest plugins responses: []

!ENTRY org.eclipse.e4.ui.workbench 1 0 2019-05-16 08:43:17.720
!MESSAGE Katalon version: 6.1.5

!ENTRY org.eclipse.e4.ui.workbench 1 0 2019-05-16 08:43:17.749
!MESSAGE Plugin info URL: https://store.katalon.com/api/products/ks?appVersion=6.1.5

Probably similar situation is described here: Katalon Studio Linux - how to refresh plugin ?


#12

that did it sir. thank you. using the api key as the pwd was the problem


#13

Hi there,

Am I supposed to be getting an invitation plugin re: the plugin?
I downloaded a the drag and drop plugin however, I have did not get the email.

When I reloaded the plugins, I am encountering an error message.

Thanks!
-Marijo


#15

Hi,

I tried deleting the com.kms.katalon.prefs file but I still get an error message when I reload the plugin.


#16

Hi @marias,
What error message did you encounter? Can you provide the log file? You can find it under Help > Error Log.


#17

Hi @huynguyen, Thank for your reply! This is the log file. Thanks! error_log.txt (433.4 KB)


#18

Hi @marias,
Have you changed your password recently?


#19

Within the last 2 weeks, I believe I did! @huynguyen


#20

Hi @marias
Please use the latest version of Katalon Studio and activate with your changed password, then try reloading again to see if it works.
Regards.


#21

@huynguyen it worked thanks!