Katalon Report Plugin not reloading

I am using katalon 6.3.3.I tied to install plugin Basic Report plugin.

I am getting the below seen error

Error reloading plugins
com.kms.katalon.plugin.models.ReloadPluginsException: Unexpected error occurs during executing reload plugins under account: credential: xxx@xxxx.com, endpoint: https://store.katalon.com/api/products/ks?appVersion=6.3.3
at com.kms.katalon.plugin.service.PluginService.reloadPlugins(PluginService.java:189)
at com.kms.katalon.composer.handlers.ReloadPluginsHandler$1.run(ReloadPluginsHandler.java:61)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by: com.kms.katalon.plugin.models.KStoreClientExceptionWithInfo: Unexpected error occurs during executing get latest plugins
at com.kms.katalon.plugin.service.KStoreRestClient.getLatestPlugins(KStoreRestClient.java:80)
at com.kms.katalon.plugin.service.PluginService.fetchLatestPlugins(PluginService.java:201)
at com.kms.katalon.plugin.service.PluginService.reloadPlugins(PluginService.java:74)
… 2 more
Caused by: com.kms.katalon.plugin.models.KStoreClientException: Invalid Request. Status Code: 401. Message: Unauthorized
at com.kms.katalon.plugin.service.KStoreRestClient.executeGetRequest(KStoreRestClient.java:263)
at com.kms.katalon.plugin.service.KStoreRestClient.getLatestPlugins(KStoreRestClient.java:59)
… 4 more

As mentioned in the post I didnt get any invitation to install the plugin.I could see the installed plugin in my katalon store for this account.

I tried to this too ->* Go to config⁩/⁨.metadata⁩/.plugins⁩/⁨org.eclipse.core.runtime⁩/.settings

  • Delete com.kms.katalon.prefs file and login again

Still nothing works.
Pls help me

Hi @senthani2,
I suspect that there maybe special characters in your password. Please check again and try to reset your password with new one without special characters (if any) to see if it works.

Thank You so much.
It worked when I removed the spl characters from pwd.

Now I face new problem .I use katalon 6.3.3.I downloaded the plugin 'Basic Report" and executed the Tcs using the command prompt and used the mail settings to sent the mail.
In the mail attachment I saw notepad with name ‘execution’ and didn’t find any PDF,HTML as attachment.
But I could see all the basic report attachments when I use the Version katalon 7.2.1.
But need katalon runtime engine to run using the command prompt.
Pls let me know the solution for this.

Hi @senthani2,
Can you see all the attachments if you use version 6.3.3 in GUI mode?

In 6.3.3 version, I see all the attachments when I execute in GU mode including PDF which I am expecting.
But only could see execution note pad when I run in Command mode.
PDF and all other attachments are missing.

Hi @senthani2

Can you provide the screenshots (in 7.2.1):
Project > Settings > Plugin > Report
Project > Settings > Email

Pls find the attachments in 7.2.1.
I need only for the Version 6.3.3 as 7.2.1 need ‘Katalon run engine’ to use command prompt