Error Message: "Unable to navigate to Step X of test case Y"

Hi.
I common practice is that the Log Viewer states that some test case failed.
I find the step in the Log Viewer, right click, and select “Go to this step in Script View”.
But recently I receive this sort of error universally.

I am not sure what I could have done to cause this.
It may have happened since we upgraded to Katalon Studio Version 8.
Another possibility is that we commented out a lot of code in our scripts recently.
But I can’t think of anything else.
I appreciate any suggestions.
Thank you.
Ilya

Maybe it’s a bug. To help narrow it down, can you write a simple test that forces the failure (without any comments etc) ?

Unfortunately a colleague also reported this same bug… on 8.0.1
And I just upgraded to 8.0.5 and tried the same operation, it fails with the same error.
Previously, on 7.2.1 it seems to have worked (according to my collegue) but I could not check as I don’t use that feature - I prefer the hard way the via Console tab :slight_smile:

Here is a small sample to demonstrate that . Run it and then go to the Log Viewer tab, scroll to the failed step, right click then select “Go to this step in script view” - it will be step #5 :


import com.kms.katalon.core.testobject.TestObject
import com.kms.katalon.core.util.KeywordUtil
import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI

KeywordUtil.logInfo( "Open browser Katalon website" )
WebUI.openBrowser( 'https://www.katalon.com' )

KeywordUtil.logInfo( "Execute a success step" )
def tObj = new TestObject( "//div[ @class = 'form_sign_up_email_only' ]/div[ @class = 'btn_sign_up_email_only' ]" )
WebUI.verifyElementPresent( tObj, 10 )


KeywordUtil.logInfo( "Execute a failed step" )
tObj = new TestObject( "//button[ @id = '_x_form_sign_up_email_only' ]" )
WebUI.verifyElementPresent( tObj, 10 )

// this will never happen because the failed step throws an exception
WebUI.closeBrowser()
1 Like

I have the same problem w/o any failing. It just cannot navigate to ANY step (not just to the failed ones)

@ThanhTo Can a dev check this please?

1 Like

Same problem.

@ThanhTo @devalex88 @duyluong @Jass @Shin

Some engagement please gentlemen.

Hi guys,

This issue has occurred since v7.9.1. We will add this to our backlog to fix it later.

Thanks for your report.

@duyluong: Do you guys have any ETA, when this bug will be fix?

Hi there,

This issue was planned to fix in v8.2.0 which will release on Nov, 18th.

@duyluong
Hi there.
Are you sure it will be finally fixed? I’m really tired of wasting a lot of my time just to get to the test step that caused problems. This is a STANDARD feature in every normal IDE and it was working BEFORE. Is this to much to expect from Katalon? Thanks a lot!

Hi @gdearest07,

We already collected the information and the issue is still in progress but we are so sorry for not delivering the solution in version 8.2.0.
I will keep you updated on it.

Thanks for your attention,
Nam Nguyen.

May I know which version will has this fix? I am getting very bad experience on Katalon Studio 8.2.0 due to this issue.

1 Like

I appreciate that the bug, for you, might be frustrating, but it’s hardly a showstopper preventing you from using the application.

In the meantime, try to do what any seasoned, professional engineer would do and find another way to accomplish your task.

For bonus HERO POINTS, post any workaround here so others might benefit. :nerd_face:

ti.wang01 didn’t write that it’s preventing him from using the application. He just wrote that "I am getting very bad experience on Katalon Studio 8.2.0". And so am I, and so are the other Katalon customers who are not able to use this feature (which works in any IDE and which used to work in Katalon).