Error HTTP 404 with Chrome Driver

I am using Katalon Studio (Version : 9.3.0 ) on Sonama 14.3.1 Mac OS ( Intel Processor )
While upgrading chrome driver , I see below error

[ERROR] Error HTTP 404 executing https://edgedl.me.gvt1.com/edgedl/chrome/chrome-for-testing/122.0.6261.69/mac-x64/chromedriver-mac-x64.zip

INFO] Using WebDriverManager to resolve chrome
[DEBUG] Detecting chrome version using online commands.properties
[DEBUG] Running command on the shell: [/Applications/Google Chrome.app/Contents/MacOS/Google Chrome, --version]
[DEBUG] Result: Google Chrome 122.0.6261.57
[INFO] Using chromedriver 122.0.6261.69 (resolved driver for Chrome 122)
[INFO] Reading https://chromedriver.storage.googleapis.com/ to seek chromedriver
[DEBUG] Driver to be downloaded chromedriver 122.0.6261.69
[DEBUG] Using URL built from repository pattern: https://edgedl.me.gvt1.com/edgedl/chrome/chrome-for-testing/122.0.6261.69/mac-x64/chromedriver-mac-x64.zip
[INFO] Downloading https://edgedl.me.gvt1.com/edgedl/chrome/chrome-for-testing/122.0.6261.69/mac-x64/chromedriver-mac-x64.zip
[ERROR] Error HTTP 404 executing https://edgedl.me.gvt1.com/edgedl/chrome/chrome-for-testing/122.0.6261.69/mac-x64/chromedriver-mac-x64.zip
[INFO] Clearing WebDriverManager resolution cache
[WARN] Exception writing resolution cache as a properties file java.lang.NullPointerException
[WARN] There was an error managing chromedriver 122.0.6261.69 (Error HTTP 404 executing https://edgedl.me.gvt1.com/edgedl/chrome/chrome-for-testing/122.0.6261.69/mac-x64/chromedriver-mac-x64.zip) ... trying again avoiding reading release from repository
[DEBUG] Detecting chrome version using online commands.properties
[DEBUG] Running command on the shell: [/Applications/Google Chrome.app/Contents/MacOS/Google Chrome, --version]
[DEBUG] Result: Google Chrome 122.0.6261.57
[DEBUG] Getting driver version for chrome122 from online versions.properties
[DEBUG] Driver for chrome122 not found in online properties (using local versions.properties)
[DEBUG] The driver version for CHROME 122 is unknown ... trying with latest
[INFO] Reading https://chromedriver.storage.googleapis.com/ to seek chromedriver
[DEBUG] Driver to be downloaded chromedriver 114.0.5735.90
[INFO] Downloading https://chromedriver.storage.googleapis.com/114.0.5735.90/chromedriver_mac64.zip
[INFO] Extracting driver from compressed file chromedriver_mac64.zip
[DEBUG] Overriding former driver /Applications/Katalon Studio.app/Contents/Eclipse/configuration/resources/drivers/chromedriver_mac/chromedriver
[INFO] Driver location: /Applications/Katalon Studio.app/Contents/Eclipse/configuration/resources/drivers/chromedriver_mac/chromedriver
5 Likes

You are not alone. I would invite you to the club of the Frustrated.

image
Same here,
Cannot use chrome for testing

Same here, currently using Katalon 9.0.0

Error in test log:

It seems like your Chrome or Edge Chromium Webdriver is not up to date with your current browser. Please go to Tools > Update webdrivers to upgrade and try again

When updating Chromedriver from Tools menu I got the same message as in @ropereralk 's schreenshot.

I switched over to Firefox to keep testing for the time being.

1 Like

Experiencing the same issue since morning. I have updated the web driver with some errors

Facing the same problem since today’s driver update.
Kindly provide a fix at the earliest. @team

1 Like

They commited to release a host fix by the end of this month:

Just wait.

They shared a workaround which you may try now:

I tried this method for KS v9.0.0 on my Mac, and it worked.

Regrettably, @Elly_Tran wrote a file path

/Applications//Contents/Eclipse/configuration/resources/tools/webdriver/webdrivermanager-5.4.1-fat.jar

This path makes sense only on Mac. You yourself need to find out the appropriate path on Windows.

1 Like

Should be here for Windows:

C:\Users\YOUR USER.katalon\packages\Katalon_Studio_Windows_64-9.3.0\Katalon_Studio_Windows_64-9.3.0\configuration\resources\tools\webdriver

Hello Everyone,

I also wanted to assist by providing this documentation for a workaround: https://katalon-inc.my.site.com/katalonhelpcenter/s/article/Issue-Unable-to-upgrade-Chromedriver121

Workaround #3 will allow the automatic updating of the drivers from within Katalon Studio to work properly again.

Kindest Regards,

Jordan

1 Like

on Linux it is something like:

$ pwd
/<Base_Path>/Katalon_Studio_Linux_64-9.2.0/configuration/resources/tools/webdriver

$ ls -al
total 47180
drwxr-xr-x. 2 ibus ibus       44 Jan  5 10:29 .
drwxr-xr-x. 3 ibus ibus       23 Jan  5 10:29 ..
-rwxr-xr-x. 1 ibus ibus 48311686 Dec 27 18:29 webdrivermanager-5.4.1-fat.jar

Something similar should be on Windows, depending on the folder where the user installed it (and ofcourse, katalon version)

For KRE, seems to be something like (on linux and most probably same for windows):

$ pwd
/<Base_Path>/Katalon_Studio_Engine_Linux_64-9.3.0/configuration/resources/tools/webdriver
$ ls
webdrivermanager-5.4.1-fat.jar

the same workaround should work for KRE so, with some small pipeline patches, this may unlock also this for the users running on various CI platforms (just add a wget and some cp / mv in your pipeline prior to start your tests)

The wait is done now, the fix has been released: Support for "Chrome for Testing" in Katalon Studio - #16 by Elly_Tran

1 Like

:innocent: :face_with_open_eyes_and_hand_over_mouth:I am getting this too

Your problem has been fixed? or not yet?

resolved with katalon studio v9.3.1!

1 Like

Hi all,

We apologize for this issue which has delayed your testing projects. Our Product team has released a fix for the issue with updating Chrome WebDriver in our latest release. You can learn more by visiting the thread below: