Errors when trying to update webdriver for chrome on mac

Hello,

I am having an issue running my suite. I recieve an error that says my chrome webdriver is not up to date with my browser. My chrome is the latest version (124.0.5457.208). So far none of the tutorials seem to address this error:
[ERROR] Error HTTP 404 executing https://edgedl.me.gvt1.com/edgedl/chrome/chrome-for-testing/125.0.6422.60/mac-x64/chromedriver-mac-x64.zip

[INFO] Clearing WebDriverManager resolution cache

[WARN] Exception writing resolution cache as a properties file java.lang.NullPointerException

[WARN] There was an error managing chromedriver 125.0.6422.60 (Error HTTP 404 executing https://edgedl.me.gvt1.com/edgedl/chrome/chrome-for-testing/125.0.6422.60/mac-x64/chromedriver-mac-x64.zip) … trying again avoiding reading release from repository

[DEBUG] Detecting chrome version using online commands.properties

I tried looking into manually updating but I am lost. Thanks in advance

1 Like

Hi there,

Thank you very much for your topic. Please note that it may take a little while before a member of our community or from Katalon team responds to you.

Thanks!

manually update failed ?

@exspillane

Which version of Katalon Studio are you using? Possibly your KS is older than v8.6.6

See

Possibly you need to upgrade your KS to v8.6.6 or newer 9.x and try update webdriver again

Thanks for your response! I’m currently on 8.6.8 so I don’t think the version is the problem

The hostname of the download URL https://edgedl.me.gvt1.com is a wrong one, which was used up until the middle of February 2024, but the URL is NOT accessible now (May 2024). Have a look at the following post:

I believe that you have a version problem which was fixed in the version 8.6.6 of Katalon Studio. But you wrote:

No. The above message (https://edged1.me.govt1.com) revealed that you still miss a correct version of WebDriverManager in your Katalon Studio.

There was a lot of discussion in Feb this year about the failure in updating ChromeDriver. Please try to find a solution in the posts liked above if you want to stay with v8.6.8 for some reason…

Alternatively, remove the current installation of KS from your mac, then download the latest version and install it.

1 Like