Website won't load when using Chrome in Record Web

Hi there,

I’m using the latest version of Katalon Studio (V8.4.1) and my Chrome drivers are up to date.

When I use Record Web, and keep the default as Chrome, when I start Chrome opens successfully and loads the website: https://app.safeagsystems.com

On the login page I enter the following login details (this is a testing account, so it’s okay to share):

Username: automationsafeagsystems@gmail.com
Password: Testing1

Click Login then I’m taken to Select subscription where I select ‘Automation Test Farm 1’. After selecting this, I get a continuous loading spinner and the website never actually loads. See below video:

I’ve even left it for a long while to see if it loads over time, but nothing changes. This is happening in Chrome and Edge, and I only noticed it happening after the update to V8.4.0. Previous to that, I never had any problems.

Firefox loads the website successfully (see video below), but it’s quite laggy.

This is affecting my work badly as Chrome is our preferred browser and as I said above, Firefox is laggy and frustrating to use.

Any advice on how to fix this will be greatly appreciated.

@Lisa1, after reproducing your issue from our side, we can confirm that this issue also happens with Chrome when recording your website in KS ver 8.2.5 and ver 8.4.1. We also tried it manually, and the website can load it successfully, so this is probably a bug from our side. You can change this inquiry into a bug report, and we can submit a ticket to the Product Team to check.

2 Likes

Hi
Is there anyone who can help me out
Currently in Katalon Studio , Chrome works on No protection (not recommended), how to change setting , if we need to test on Enhanced protection.

@chen.lee thank you very much for your response. Can you please advise how I change this inquiry into a bug report? I don’t seem to have any options to edit or add additional tags.

I can help do that for you

1 Like

@Lisa1 the Product Team suspects the website forever loading is a software defect or an issue caused by Chrome, not an issue of Studio. The reason is they went to the website, logged in with the account, and it kept loading. You can check the result here. They conclude that’s not an issue of KS.

You can try checking this article Google Chrome Won't Load Web Pages | Small Business - Chron.com to see if it helps.

I studied the original post.

  1. In Chrome, I navigated to https://app.safeagsystems.com with Username: automationsafeagsystems@gmail.com , Password: Testing1 to select “Automation Test Farm 1”. I got continuous loading spinner. I could reproduce the problem.
  2. I did this all manually on Chrome without Katalon Studio, without Record Web.
  3. I tried the same in Firefox. It worked OK. I could successfully log in to the site. I found no problem.
  4. I observed the behavior of the system, and I guessed that an HTTP request from browser to the server disappeared somehow. The request was sent by Chrome browser but not received by the server app. The server app did not received any request, so that it was not responding at all.

I suppose that this problem occurs only with the combination of Chrome and your web server app. Katalon Studio has nothing to do with this problem.

I read the source of page’s HTML and found that the web site works on top of the cloudflare service.

I made a quick search with keyword “cloudflare chrome”. I found the following issue:

“Cloudflare not working on Chrome” — this post should be interesting for you. It suggests that you might want to change the config of web server app or of the cloudflare.

At least, you should check the log of the web server to find out how the HTTP requests were processed. I guess, you would find some records that tell an HTTP request for login was discarded by the HTTP server for some reason (too many HEADERs).