Using Browserstack remote through Katalon, anything Java on the page doesnt display. And I need it to

Hi Knowledgeable people in my computer :slight_smile:

I have set up a number of tests, to use in Browserstack. that I run using the remote section. However, I have lost anything Java related, which means my test is unable to hook/run the section that I need as it is Java. I have turned off smart wait, as apparently that can cause issues, but its still the same, so wasnt sure if anyone had come across it before and had an idea as to what I can do to get it back.


This is the “error” that I get


I will treat anyone who resolves/helps my issue with cake as its driving me mad!


Have you set wait for the element? Element not interactable - Katalon Studio - #6 by dominik.ber

The element doesnt appear as no Java elements are coming through when I automate it through Katalon. Thats my issue :(.

Does it fail only in browser stack or other platform providers too?

Only when I use it through Katalon. If I use browserstack on its own, its fine, all the Java is there. All my automation tests, through Katalon are fine, its just browserstack. Literally scratching our heads over it and have reached out to browserstack but not really going anywhere, hence asking here in case someone had encountered it.