Element not interactable -Bug

Hello Group,

The test I’m trying to run, I need to click on the highlighted element and scroll down to choose the element to delete. I ran the test and it says it passed but when I go to the website the element is still there, is this a known issue? Here are screenshots of my element I need to test, code and says it passed.

test 1 test 2

Is this clicking the right thing?


Do you see this confirmation dialog appear?


I don’t see the test clicking on the object? and no the confirmation dialog does not appear.

Then you should check the definition for this test object:

Also, what are the error message you see?

it’s defined by it’s xpath, which I found via inspect, copy xpath. I still get no error.
here is my full code

import static com.kms.katalon.core.checkpoint.CheckpointFactory.findCheckpoint
import static com.kms.katalon.core.testcase.TestCaseFactory.findTestCase
import static com.kms.katalon.core.testdata.TestDataFactory.findTestData
import static com.kms.katalon.core.testobject.ObjectRepository.findTestObject
import static com.kms.katalon.core.testobject.ObjectRepository.findWindowsObject
import com.kms.katalon.core.checkpoint.Checkpoint as Checkpoint
import com.kms.katalon.core.cucumber.keyword.CucumberBuiltinKeywords as CucumberKW
import com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords as Mobile
import com.kms.katalon.core.model.FailureHandling as FailureHandling
import com.kms.katalon.core.testcase.TestCase as TestCase
import com.kms.katalon.core.testdata.TestData as TestData
import com.kms.katalon.core.testng.keyword.TestNGBuiltinKeywords as TestNGKW
import com.kms.katalon.core.testobject.TestObject as TestObject
import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WS
import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI
import com.kms.katalon.core.windows.keyword.WindowsBuiltinKeywords as Windows
import internal.GlobalVariable as GlobalVariable
import org.openqa.selenium.Keys as Keys

WebUI.callTestCase(findTestCase(‘Staging Login’), [:], FailureHandling.STOP_ON_FAILURE)

WebUI.click(findTestObject(‘Object Repository/add note/a_Quick ViewReport In Progress25ATAlexTapia_aa8f35’))

WebUI.click(findTestObject(‘add note to order/Page_2341 Collins Ave Orders Anow/Message spot’))


WebUI.waitForElementVisible(findTestObject(‘Edit Order Message/Page_125 Beech St Orders Anow/3 dots’), 10)

WebUI.focus(findTestObject(‘Edit Order Message/Page_125 Beech St Orders Anow/3 dots’))

WebUI.click(findTestObject(‘Edit Order Message/Page_125 Beech St Orders Anow/button_Delete-OM’))

WebUI.click(findTestObject(‘Edit Order Message/Page_125 Beech St Orders Anow/button_Confirm delete-OM’))

test 5

The HTML from devtools inspector with the button highlighted would be good. If you use Firefox, I’ll be able to see more.

i use a few different pluggins like html and katalon notes

I finally got it to work, I changed the code. I added mouse over the element and that worked. thanks for all your help

1 Like