Unable to rename Test Object or Folder when copied

I’ve already completed the “core” part of my project and now next step is to replicate this on different modules of my project

So I tried to copy test objects and folders in my Object Repository (Why? Since my module has similar structure and its more efficient to copy an object than create a new one) then I encountered the ff. issues:

  1. Unable to rename Test Object
  • If you copy an object and tried to rename it, Katalon will prompt an error. BUT if you try to navigate it in Windows Explorer the object you just tried to rename just got rename. AND Refreshing will not show it got renamed

Temporary solution: Edit the object in your text editor (yes I know its a hassle) like put a space anywhere the refresh in the object’s folder and you will see the changes (rename and extra space in your locator)

  1. Unable to rename folder
  • This one is worse. If you tried to copy a folder then renamed it, the objects inside that folder will no longer be shown in Katalon

Temporary solution: Rename the folder again using Windows Explorer then refresh in Katalon

  1. Unable to move the selection: null
  • Worst so far. This issue happens if you try to move object(s) or folder

    3.1. If you move an object, you just have to press OK to close the error then refresh to see both the source folder and target folder (Why? Because if you dont refresh both folder and just keep moving this same object it will keep create copies)

    3.2. If you move multiple objects, you can only move 1 successfully the others remain but you still need to refresh both folders

    3.3. If you move a folder, it will create a copy for this folder to the target folder along with the objects inside that folder. BUT this same folder will remain in the source folder without its objects


  • I encounter these errors in v7.7, v7.8.0, v7.8.1 but its less apparent in v7.3.X that I’m using before

  • These issues only happen in Object Repository, not replicable in Test Case and Test Suite

I suggest for now, don’t try to copy and move in Object Repository. Just keep creating new one.

#3 Please let us know what you are using Katalon Studio for?

  1. I’m exploring the tool
  2. I’m building a Proof of Concept
  3. I have currently applied Katalon Studio in my project
  4. I’m learning automated test with Katalon Studio

#2 How would your work be affected if this issue has not been resolved?

  1. It doesn’t affect much, but I believe Katalon team should have this ticket resolved
  2. I can continue my job, resolving this ticket can boost my performance
  3. I can continue my job, but my performance is lower than expected
  4. I cannot continue my job and have to work on something else while awaiting your response
  • Katalon Studio Version: 7.8.1
  • OS Version: Windows 10
  • Browser Version: Chrome 86.0.4240.198

Screenshots / Videos

1 Like

Shout out @ThanhTo @duyluong @Jass

@kenneth.montevirgen I agree these bug-points need to be fixed but if you extend your modular approach, there are ways to use Katalon Studio without using the Object Repository. When this topic is solved, perhaps post a question “How to avoid using OR for Test Objects?” and we’ll help you there.

1 Like


Please provide us with the error log file under Help > Error Log when you reproduce this issue.

@ThanhTo sent you the logs via message here. Let me know if that will suffice

Can you give a sample? I’ve build the project so our Client can easily grasp the structure

Like I said, let’s fix your issues first. We’ll deal with that in another thread.

But if your clients are non-technical, then you might want to stick to the OR.

Hi! Sorry forgot to update this item. Already resolved this.

Root Cause: Git conflict that causes the object to not display or found in Katalon hence I completely forgot it exists

Solution: Open the object in text editor then resolve the conflict

Thanks @ThanhTo for checking the logs last Dec and identified the object that causes this