Test Suite Collection


This is a companion discussion topic for the original entry at https://docs.katalon.com/katalon-studio/docs/test-suite-collection.html

Hi! I can see Run With (FIrefox, Chrome…) in Test Suite Collection

Did you say you CAN see the run with option? because i installed what i believe is the latest Katalon Studio version and i do NOT see that option, any idea why?

Hi,

I tried to execute the test suite collection when i added two test suite in a test suite collection.
First one is Login and another one is check filters. Then the first one ran successfully but second was thrown exception like browser is not open exception. So how to handle this type of exception.

Someone kindly assist me.

I am also facing the same issue…

I had added 2 Test suites (that with two test cases enabled/ marked in each suites) inside the test suite collection. After I executed, Test suite 1 was successfully executed but When goes to Test Suite 2 the browser closed automatically (Test Suite 2 is not executed). Please find the reason below,

Use of “Test Suite Collection” is to add the same test suite (that with single test case only, if multiple test cases means enable single test case only) multiple times and run parallely with different browsers.

Reason for the issue when i run the first test suite it will run successfully, but the second one will through exception means first test suite having the browser opening code. but second doesn’t have opening code. so it try to open new window. but i want to open the second test suite also in same session or window.

Someone please check that one

@satinder.tester2019 @dhamodharan.ravichan @kowsalrajk Usually Katalon will execute every test case separately in a new session every time. It won’t care if the Browser was already open in the previous test case.

There are some ways you can utilize in https://docs.katalon.com/katalon-studio/docs/setupteardown-for-test-suite-and-test-case.html

Have you resolved? After my last update i have same problem

Im also seeing the issue kfarhat is seeing, I dont have the run with option. It was there yesterday and I have an older project that does have it, but any project I create today does not have the option to set the browser within the test suite collection.

I’ve updated to Katalon Studio 6.2.0 - build 1. Issue with not seeing “Run with” seems to be resolved now.

I also updated and I can see the Run With section now but I cannot select the browser.

I was able to get it to run in Chrome by editing the script manually, it errors but seems to be a false error and my suites run properly.

Hi, In version 6.2.0 I don’t see many options in the “Run with” field. I only see the Web Service option, Is this a bug in this version?
Is there something I am missing?
I have 2 test suites in this collection that are supposed to run, one in chrome browser and the other in android, they need to run sequentially since there are some sync activities to be performed.

Please,your help will be really appreciated

Does Katalon support running on two Android devices? I have added two Test Suites with one different test case in each suite and I have set one test suite Run configuration to one device and the other test suite to the other device. WIth Parallel set, when I execute, it is running both tests on the same device but one at a time. Any suggestions

Hi,

Is there any way where we can run a block of code after the Test Suite Collection runs?

I have a scenario where I need to create a file only once and only after all the Test Suites(Test Suit Collection) have completed their execution. Currently, I am using the TestListeners @AfterTestSuite, but it doesn’t work for me because it runs after each Test Suite.

Is there anyway to run the Test Suite collection in a CI/CD pipeline, such as bitbucket? If yes, do I give the collection name?

Hi! Have you resolved? I have the same issue and don’t know how to fix…

Open the .prj file of your project with a text editor and change the type to generic.

      </systemFolderList>
   </sourceContent>
   <type>GENERIC</type>
</Project>
1 Like

Thank you for quick reply!!! It works!!!