Run Katalon test and get stuck on Linux Server with Proxy needed

I try to run a Test on linux server with the next:

katalon -noSplash -runMode=console -consoleLog -projectPath=“routeAbsolute” -retry=0 -testSuitePath=“routeRelative” -browserType=“Firefox (headless)” -email=“validUser” -password=“validPassword” --config -proxy.option=MANUAL_CONFIG -proxy.server.type=HTTPS -proxy.server.address=“serverAddress” -proxy.server.port=“port” -proxy.username=“validProxyUser” -proxy.password=“validProxyPass”

And test get stuck…

If I go to the “/srv/config/.metadata/.log” appears the next:



I get the same result if I introduce a no valid account. Then it seems the proxy is not working properly.

Do you know a way to detect if the katalon has success on a validation account?

Or a way to check if the --config parameters are well introduced?

I’m using Oracle JDK.

Do you start that via some CI tool like Jenkins?

Hi Mariusz,

I’m using directly the line command. Without any CI tool.

I’ve tried to launch it using OpenJDK but it still not working :(.

I don’t know why the console log does not write anything…

Try to export http(s)_proxy as env in linux. Maybe that will help?

:frowning: yes, I’ve tried that.

The netstat says that we are estabilishing connection to katalon page (to validate account?)…
(Using both options with proxy as --config parameter and env on linux)

OS version CentOS Linux release 7.2.1511 (Core)

If I put -verbose on katalon.ini console:

I get the next:
… some text loading .jar files…

[Loaded org.eclipse.equinox.internal.util.threadpool.ThreadContext from file:/opt/Katalon_Studio_Linux_64-5.4.1/plugins/org.eclipse.equinox.util_1.0.500.v20130404-1337.jar]

[Loaded org.eclipse.equinox.internal.util.impl.tpt.threadpool.Executor from file:/opt/Katalon_Studio_Linux_64-5.4.1/plugins/org.eclipse.equinox.util_1.0.500.v20130404-1337.jar]

And finally it get stuck…

Any more ideas? I appreciate your help.