Regarding freezing the IDE

I often get GC overhead limit exceeded error in KTS 6.3.3 windows x64 bit.

image

Regrds
Abhishek

Hi,

check this chain

I had already tried but it didn’t worked for me…

Thanks

hi,

what kind of OS and capacity you have?

Wndows x64 bit, 8 GB Ram, intel cire i3

hello,

check your katalon.ini file
i have

-Xms256m
-Xmx2048m

rise Xms to a decent value. at least 1024 or even Xmx value. if you don’t understand why, read a bit about java garbage collector.

@ThanhTo now seriously. i think is time to reconsider the defaults. those days, xms 256 is … hilarious.it may suit for cli running only, but for gui … mhmpf. just saying

1 Like

Sure will do and let you know the feed back

@Abhishek_Kumar_Gupta you can tweak the xmx too … but take care with it. increasing it, you may unleash the java devil … i will suggest never go with this value above half of your physical installed RAM … unless you know what are you doing. expect major damage

hi,
sorry, those were my old values now i have
-Xms1024m

1 Like

Thank you for the feedback. In version 7.0 we’ve made some improvements on memory usage.

try this within visual studio

tools --> options --> text editor --> C#

disable Auto list members and Parameter information.

I have C# source which has more than 10,000 lines in a file and it doesnt cause any problems. Maybe its because my laptop has 4GB ram.