Proxy not used while recording, only when re-running test cases


#1

Hi Everyone - We need our proxy to run while both recording test cases, as well as re-running them. After experimenting for some time, and with this very simple configuration, no web requests connect to the proxy while recording. The proxy is only being used when re-running saved test cases.

image

This has been confirmed on several machines, all of which have updated to the latest version of Katalon Studio, and the latest version of Chrome. As our tests need to be recorded under the same conditions that they are run, this is a road block… and trying anything programatically outside of standard Katalon options is unfortunately not an option.

Has anyone else experienced this? Any suggestions?

Thanks!
Matt


#2

In which version of Katalon Studio do you find this problem?


#3

If the problem is specific to a particlar version of Katalon Studio, you can try using older releases. You can get the older versions at:


#4

Thanks… I’m testing some previous versions now. We’re experiencing the issue in 6.3.3. As you can see, in 6.3.3, the proxy parameters are never sent through to Chrome, on “record”…

image


#5

To follow up, we tried the following versions…

image

In all test cases, we see no proxy being used during the record process:

image

but we do see it used when re-playing a test case:

image


#6

@matthew.bayuk

Katalon Studio provides 3 options of Proxy setting:

  1. No Proxy
  2. Use system proxy configuration
  3. Manual Proxy Configuration

Which option do you use? #2 or #3?

I suppose that you use #2 “Use system proxy configuration”. If so, why not you try #3 “Manual Proxy Configuration”.

I personally use #3. I never use #2. I forgot the detail but once I encountered some problems with #2, so I changed to #3.


#7

See also


#8

If you’ll see my first post, i pasted our proxy settings… it is an internal proxy that we need to use, and recording would not work without it. You can also see above in the command line that Katalon sends to Chrome, Katalon isn’t sending any of those proxy settings to the browser when initiating a recording… so Katalon isn’t even trying to use the proxy, correct?


#9

OK, I see it.

I am behind a corporate proxy, and I do not see problems like yours. I looked at the screenshot you provided, and found a difference from my case. Your proxy has type “HTTPS”, while my proxy has type “HTTP”.

Anyway, I would agree that Katalon Studio seems to have some problem as you reported. It needs to be checked by the team: @devalex88, @ThanhTo, @duyluong


#10

Hi @kazurayam, @matthew.bayuk,

This was the top result on Google for “katalon proxy not used while recording” (we must think alike) and I’m here to report I’m also having the same trouble with Katalon that Matthew is.

In my case, I’m using Charles on Mac (Mojave) and Fiddler on Windows 10 to modify requests before they’re submitted to the server and my experience is identical to what was posted above–no proxy settings show up in chrome://version on the command line when recording.

I’ve been using the manual configuration for the proxy and have tried HTTP and HTTPS. The proxy settings specifically not used when recording. During playback, the proxy settings are used.

I’m hoping this is a simple fix that could be pushed out in the next Katalon update. If this is currently being investigated by the development team could someone comment on status/tentative plans? I have a rather urgent need for this functionality to be working for me to continue using Katalon.

I’m new, but let me know if I can help assist in any way!

Thanks for your time and attention!

quick update: I am also using Katalon 6.3.3 on Mac/Mojave


#11

Hey All,

Is this forum the best way to get in touch with someone about a fix for the issue in this thread? If there is a better way to garner a response I’d happily resubmit the issue in a new format or different system.

Thanks in advance!


#12

@kazurayam @devalex88 hello?