Mobile on macOS

This is a companion discussion topic for the original entry at

I want ask something, May it be installed Katalon android and iOS at the same time in one macOS?

if you mean by installing android sdk and iphone virtual device, yes you can. I use Android studio and xcode

ohh i see, i use android studio now to automated android. nahh next quarter automated iOS, so i plan use xcode. thank you purbo for your answer

After uninstall and reinstall of Xcode, the project.pbxproj file is missing

after two weeks katalon not work with ios devices…

what’s the solution?

Devices are recognised for me but I cannot create tests. Error message “Unable to start application. Reason: String index out of range: -6” appears.

Hi @Katalon_team,
My physical iphone 6 is connected but is called “” on Katalon, no issue on Xcode - Device and Simulator

this is My local Component:
Appium: 1.17.0
Mac OS: 10.14.6
Xcode: 10.1
Carthage: 0.34
iOS-deploy: 1.10
iOS-webkit-debug-proxy: 1.8
Libimobiledevice: 1.8.6
usbmuxd: 2.0.1

Hi @jefri.zhang,

Could you share your screenshot of the Devices dialog?

Hi @thongnmtran

this is for android

This is ios device

and sorry, I’m not sure where to find ur menu on my Katalon 7

1 Like

Hi @jefri.zhang,

Yeah, your provided screenshots are very useful /=). You could follow this post to fix that problem.

Hi @thongnmtran
But my mac is version 10, I can’t upgrade the Xcode to 11

so when I run brew install --HEAD usbmuxd and brew install --HEAD libimobiledevice, it will prompt this error

I just run brew install usbmuxd and brew install libimobiledeivce

But, after complete all these step, it still unrecognized.

Additional information,
my above picture that contain ios unrecognized device with error log that state deviceName can’t be blank, actually I ord set it, yet it still not working

Hi @jefri.zhang,

Could you try to update your macOS version, and XCode too /=),
In case you cannot do that, I suggest the following solution. Reinstall all dependencies.

First, uninstall all the dependencies ( libimobiledevice , ios-webkit-debug-proxy , usbmuxd , ios-deploy and carthage)

$ brew uninstall --ignore-dependencies --force libimobiledevice && brew uninstall --ignore-dependencies --force ios-webkit-debug-proxy && brew uninstall --ignore-dependencies --force usbmuxd && brew uninstall --ignore-dependencies --force ios-deploy && rm -rf /usr/local/bin/ios-deploy && brew uninstall --ignore-dependencies --force carthage

And then, reinstall all of them in this right order

$ brew install carthage
$ brew install ios-deploy && brew unlink ios-deploy && brew link --overwrite ios-deploy
$ brew install usbmuxd && brew unlink usbmuxd && brew link usbmuxd
$ brew install libimobiledevice && brew unlink libimobiledevice && brew link libimobiledevice
$ brew install ios-webkit-debug-proxy

If this still doesn’t work, you will have to find out which versions of usbmuxd, libimobiledevice and ios-webkit-debug-proxy are compatible with the others.

Hi @thongnmtran

my mac is stuck on version 10 - Mojave, so does the Xcode.

Ok, Let me try to uninstall and install again. Will get back to you later

1 Like

Hi @thongnmtran,

done uninstall and install but still unrecognized

If this still doesn’t work, you will have to find out which versions of usbmuxd, libimobiledevice and ios-webkit-debug-proxy are compatible with the others.

is there any document that can help me to get this compatible information? encountered some trouble as most of information on web is talking about appium version below than 1.15

Hi @thongnmtran

How can I install a specific version using brew?

and how can I install using ‘package’?

found this information
not sure it is about compability or what. but those listed version of librabry are match with mine

Usbmuxd 2.0.1
Libimobiledevice 1.2.0_6
iOS-webkit-debug-proxy 1.8.6

Hi @jefri.zhang,

To install custom package of libimobiledevice you could go to the releases page here. The installation instructions are also here.

But before that, could you run this command line for me

$ idevice_id -l


ok, will try to take a look on release page, but libimobile 1.20 should be the best right?

yeah, maybe you should try that /=)

But, it is ord same as my local

Hi @jefri.zhang,

Your installation looks okay. Could you run one more command line (replace the device_id by the id you got from the previous command “idevice_id -l”)

$ idevicepair pair -u <device_id>