Load from WSDL not recognising imports


#1

Hey there,
im encountering a problem when trying to do some API-tests. I can load a WSDL from an URL, but Katalon does not load/recognise imported xsd-files. When i run a request i get this error:

“… An error occurred trying to resolve schema referenced at ‘somexsd.xsd’ …”.

Basically Katalon is missing this xsd in its homepath:

“This file was not found: file:/C:/dev/katalon/Katalon_Studio_Windows_64-6.2.0/somexsd.xsd”

In the WSDL it looks like this:


xsd:schema
<xsd:import namespace=“http://someNamespace” schemaLocation=“somexsd.xsd”/>
</xsd:schema>

Is it possible for Katalon to recognise and import this xsd-files automatically?

Greetings,
Adrian


#2

Hi @Adrian.Skirzynski,
Please download Katalon Studio 6.3.0 rc5 from https://github.com/katalon-studio/katalon-studio/releases and try again.
Regards.


#3

Hi @huynguyen,
i tried with the new version. Unfortunatly there is another issue now. It looks like Katalon recognises the imports and tries to use them, but it searches in the wrong folder/place.

The URL is: https://…/someService/META-INF/wsdl/someService.wsdl

Now, lets say there is an import statement for somexsd.xsd

Where Katalon searches:
https://…/someService/META-INF/wsdl/someService.wsdl/somexsd.xsd
The somexsd.xsd just gets attached to the end of the url. But it should be:

https://…/someService/META-INF/wsdl/somexsd.xsd

Greetings,
Adrian


#4

Hi @Adrian.Skirzynski,
Can you provide your endpoint to help reproduce the issue?
Regards.