Katalon studio web recorder NOT capturing objects via IE 11

## OS : Windows 10 enterprise 64 bit

*Client wanted to test and learn the tool before using it so they have provided a virtual desktop for doing a proof of concept.

## Katalon Studio Version :

Version: 5.4.1
Build: 1

## Katalon Studio logs:

log attached

## Environment (for Web testing)

Browser: IE 11.2248.14393.0
update version: 11.0.65

*Both recorder and object spy extensions are installed and the add on is enabled in IE browser.

*I have created the BFCACHE key in registry. for 64bit.

*In the Internet option → security tab the severity level was set as
Internet - custom setting
local intranet - custom setting
Trusted sites - Medium
Restricted Sites - High

I’m unable to set the same severity level for all the security setting due to enterprise security team does not allow it to change.

*I don’t have JDK installed in the virtual desktop, but have jre1.8.0_131
*No JAVA_HOME set in the environment variable. Not sure if we need this for the recorder.

## Steps to reproduce -

→ double click Katalon.exe
→ once the Katalon Studio opens click “record web” icon
→ in the web recorder pop up provide an URL (internal URL provided).
→ click the internet explorer icon placed after the URL text box.
–>once the page is opened in IE click the username text box

## Expected Behavior -

→ once the web page is opened in internet explorer
→ i click on the username text box
→ the objects should be captured and shown in the web recorder

## Actual Behavior -

→ The website is opened and the login page is displayed
→ when i click the username text box or any other elements in the web page it is NOT shown in the recorder actions list.
→ No error message is shown
Note: does not capture for any URL, internal or external.

.log

Hi Karthick,

Based on your provided information, I guess the root causes of your issues due to:
- Configurations.
- Connection policy.

So here are some workaround solutions:
- Configurations:
https://docs.katalon.com/display/KD/Troubleshoot+web+automated+testing#Troubleshootwebautomatedtesting-UnabletorecordonInternetExplorer

By the way, same security level from our guide means if you’ve either enabled or disabled protected mode for one zone, then all other zones should be either enabled or disabled. Please check this configuration again.

- Connection policy:
https://docs.katalon.com/display/KD/Troubleshoot+web+automated+testing#Troubleshootwebautomatedtesting-UnabletoconnecttoKatalonserver

By the way, can you help to provide a picture too ?

Thank you all for reporting this issue. Please uninstall the current IE add on, then install the new version here https://github.com/katalon-studio/katalon-studio-ie-addon/releases/tag/v1.1.0 and let us know the result.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.