Katalon Analytics Agent issues?

Both of my Agents stopped working last night, checking the logs and this is the response the agents are. getting back when trying to connect to Katalon Analytics.

[> 2020-04-17T09:51:51.009] [INFO] katalon - Getting server profiles…

[2020-04-17T09:51:51.242] [INFO] katalon - GET https://analytics.katalon.com/info 403.

[2020-04-17T09:52:51.069] [INFO] katalon - Getting server profiles…

[2020-04-17T09:52:51.308] [INFO] katalon - GET https://analytics.katalon.com/info 403.

[2020-04-17T09:53:51.129] [INFO] katalon - Getting server profiles…

[2020-04-17T09:53:51.439] [INFO] katalon - GET https://analytics.katalon.com/info 403.

[2020-04-17T09:54:51.189] [INFO] katalon - Getting server profiles…

[2020-04-17T09:54:51.495] [INFO] katalon - GET https://analytics.katalon.com/info 403.

[2020-04-17T09:55:51.249] [INFO] katalon - Getting server profiles…

[2020-04-17T09:55:51.492] [INFO] katalon - GET https://analytics.katalon.com/info 403.

[2020-04-17T09:56:51.309] [INFO] katalon - Getting server profiles…

[2020-04-17T09:56:51.618] [INFO] katalon - GET https://analytics.katalon.com/info 403.

@ThanhTo Please help! I have rebooted the server several times, it looks like the analytics server that the agent connects to is down?

Hi @shahin.fard

1/ Can you access to https://analytics.katalon.com/info site from the machine which your agents run on ?
Show us what you get when accessing to https://analytics.katalon.com/info site from the machine which your agents run on.

2/ Please going to https://analytics.katalon.com to setup a new agent and tell us if the problem still persist

These machines are headless servers running Unbuntu… I try to ping the server and I get ping: unknown host analytics.katalon.com/info

@quile @Thong

I have removed the old Agent file, created a new one and started the service… I am getting the same error…

[2020-04-17T11:06:49.851] [INFO] katalon - Agent v1.2.0 started @ Fri Apr 17 2020 11:06:49 GMT-0600 (Mountain Daylight Time)

[2020-04-17T11:06:49.855] [INFO] katalon - Loading agent configs @ /home/sha/KatalonAgent/agentconfig

[2020-04-17T11:07:49.894] [INFO] katalon - Getting server profiles...

[2020-04-17T11:07:50.213] [INFO] katalon - GET https://analytics.katalon.com/info 403.

[2020-04-17T11:08:49.954] [INFO] katalon - Getting server profiles...

[2020-04-17T11:08:50.270] [INFO] katalon - GET https://analytics.katalon.com/info 403.

1/ Run this command in your headless server and show us what you get
curl https://analytics.katalon.com/info -v

2/ Please checking the internet connection of the headless server

@quile I’ve checked the internet connection and its fine… I have 2 servers in different locations that are throwing the same error and it appears to have happened at the same time… I just did the curl you requested this is the response

> Trying 54.157.0.71...
> 
> * Connected to analytics.katalon.com (54.157.0.71) port 443 (#0)
> 
> * found 148 certificates in /etc/ssl/certs/ca-certificates.crt
> 
> * found 592 certificates in /etc/ssl/certs
> 
> * ALPN, offering http/1.1
> 
> * SSL connection using TLS1.2 / ECDHE_RSA_AES_128_GCM_SHA256
> 
> *  server certificate verification OK
> 
> *  server certificate status verification SKIPPED
> 
> *  common name: katalon.com (matched)
> 
> *  server certificate expiration date OK
> 
> *  server certificate activation date OK
> 
> *  certificate public key: RSA
> 
> *  certificate version: #3
> 
> *  subject: CN=katalon.com
> 
> *  start date: Tue, 21 May 2019 00:00:00 GMT
> 
> *  expire date: Sun, 21 Jun 2020 12:00:00 GMT
> 
> *  issuer: C=US,O=Amazon,OU=Server CA 1B,CN=Amazon
> 
> *  compression: NULL
> 
> * ALPN, server accepted to use http/1.1
> 
> > GET /info HTTP/1.1
> 
> > Host: analytics.katalon.com
> 
> > User-Agent: curl/7.47.0
> 
> > Accept: */*
> 
> > 
> 
> < HTTP/1.1 200 
> 
> < Date: Fri, 17 Apr 2020 17:14:36 GMT
> 
> < Content-Type: application/vnd.spring-boot.actuator.v2+json;charset=UTF-8
> 
> < Transfer-Encoding: chunked
> 
> < Connection: keep-alive
> 
> < X-Content-Type-Options: nosniff
> 
> < X-XSS-Protection: 1; mode=block
> 
> < Cache-Control: no-cache, no-store, max-age=0, must-revalidate
> 
> < Pragma: no-cache
> 
> < Expires: 0
> 
> < Strict-Transport-Security: max-age=31536000 ; includeSubDomains
> 
> < X-Frame-Options: DENY
> 
> < 
> 
> * Connection #0 to host analytics.katalon.com left intact
> 
> {"git":{"commit":{"time":"2020-04-17T04:02:42Z","id":"b5e9109"},"branch":"b5e910905b939236955dc8864c4e9d2ad30ed4e8"},"build":{"version":"0.20.0","artifact":"kit","name":"kit","group":"com.katalon.kit","time":"2020-04-17T04:09:42.835Z"},"profiles":{"active":["fixed","aws","production"]},"stripePublicApi":"pk_live_P8N9j20x97UIvJ6CGxMXDFg8"}

@quile @ThanhTo @Thong

I need to know our next steps, we have regular tests that are scheduled to run throughout the day… Its a bad day for this to stop working

I was able to install the KRE manually and kick off an execution as a work around… However at the end of the execution when it goes to upload the results to TestOps this is the error it returns, please advise next steps.

Katalon TestOps: Unexpected response, URL: https://analytics.katalon.com/api/v1/katalon/test-reports/update-result?projectId=42533, Status: 403, Response: {“error”:“access_denied”,“error_description”:“Either this resource does not exist, or the current user does not have permissions to access this resource”}

Apologies for this issue. It seems that Amazon Firewall had mistakenly blocked requests from your agents. I’ve disabled the Firewall. Please try again and let me know.

1 Like

Thanks for posting this @shahin.fard, I’m brand new to Katalon and have been trying to get my agent to run for several hours now. There hasn’t been a lot of help found online. I’m in the same boat as you are. I can get to the site that you were asked to and this is what I see:

Cheers

Thank you we are back :smiley:

Have you sorted out your agent yet?

Yep, I believe so. I can now see the Agent in the Dashboard. Thanks for checking; greatly appreciated.

1 Like