Do not receive the Katalon Server Token

Dear,

I’m not getting the token request on Katalon, I wonder if it has any address or protocol to be released.

Where I am we have firewall and proxy but when trying to execute the procedure does not return anything in the log of them.

If it has another URL that it calls internally, I will need to release it in the rules, it works normal browser access to Analytics.

Thank you

snipaste_06-08-2018_11.12.35.png

Hello @5725-Eduardo

Based on the screenshot, the possible cause is wrong email or password info. Please double check again.

Also, you’ve mentioned that you are behind firewall/proxy. Have you configured the proxy in-app Preferences? If not, refer to this document.

In case the problem still persists, please provide the app log for us to further investigate. Refer to this guide for extracting the log.

Thank you for using Katalon products,
Liam

Hi Liam,

In check we found that giving DROP in the requests, I will need the IPs used to upload to allow in the firewall on the company, but I did not find a document with this information or instructions on how we can release.

Can you help me?

Tks,
Eduardo

I also see the same result when logging into my accounts. Prior to about an hour ago, I was able to log into the Analytics website with no issues.

I am getting the same result. I was able to log in earlier. Using the website https://analytics.katalon.com/ brings up the error ‘unauthorized’ followed by the error message

'/api/v1/users/me

There is a problem occur in server side. Please contact to admin’

EDIT: Appears to be working again.

Eduardo de Faria Grangeiro said:

Hi Liam,

In check we found that giving DROP in the requests, I will need the IPs used to upload to allow in the firewall on the company, but I did not find a document with this information or instructions on how we can release.

Can you help me?

Tks,
Eduardo

Hello,

Please try to whitelist Katalon Studio app and https://analytics.katalon.com/ in your firewall rules.

Best,

Liam

Liam B said:

Eduardo de Faria Grangeiro said:

Hi Liam,

In check we found that giving DROP in the requests, I will need the IPs used to upload to allow in the firewall on the company, but I did not find a document with this information or instructions on how we can release.

Can you help me?

Tks,
Eduardo

Hello,

Please try to whitelist Katalon Studio app and https://analytics.katalon.com/ in your firewall rules.

Best,

Liam

Ok, I will try whitelist and return with result.

Tks

Dear,

It is released on the firewall but it is not working.

Both by Katalon Studio and by the console to manually upload:

2018-08-09 10:05:56.588  WARN 14156 --- [main] c.k.k.r.uploader.helper.KitServerHelper  : Cannot get access_token from KIT server by your credentials: eduardofari@gmail.com *******
org.apache.http.NoHttpResponseException: analytics.katalon.com:443 failed to respond

Hi Eduardo,

That’s strange. Are you able to log into Katalon Analytics successfully? If not, please try to access analytics.katalon.com through browser first and then try upload again.

Let me know if it works! If you have any further questions, feel free to follow up on this discussion.

Best,
Liam

Hi Liam,

Yes on the Katalon Analytics website I access without any problem is only in the application that generates this error.

Tks,
Eduardo

Eduardo de Faria Grangeiro said:

Hi Liam,

Yes on the Katalon Analytics website I access without any problem is only in the application that generates this error.

Tks,
Eduardo

Hi Eduardo,

Would you share your app log for the development team to take further look? In case you don’t know how, please refer to this post.

Thanks for your support,
Liam

Has this been resolved? Using v5.8.0 [build 1] - this issue continues.
I have verified that I am able to successfully go to https://analytics.katalon.com via browser and I have verified that firewall is not an issue; however, going through Project Settings --> Integration --> Katalon Anayltics results in: “Cannon request a token from Katalon Analytics server”

Daren OBrien said:

Has this been resolved? Using v5.8.0 [build 1] - this issue continues.
I have verified that I am able to successfully go to https://analytics.katalon.com via browser and I have verified that firewall is not an issue; however, going through Project Settings --> Integration --> Katalon Anayltics results in: “Cannon request a token from Katalon Analytics server”

Have you checked your proxy configuration in Project Settings? If you already did, please provide the app log for further troubleshooting.

Best,
Liam

I am seeing this again this morning when I try and log into Katalon Anaytics. Is there an outage?

Thanks,

Kim