How to use a Proxy when running on Linux in Command Line

Hi,

I have a setup with OWASP ZAP which acts like a proxy. When running on Windows, even using command line, it all works. Issue is, I need it running on Linux and when I do that, it doesn’t seem to go to proxy correctly and get a 502 error. The certificate is installed correctly. Thanks for any help or ideas

I run something like this:

./katalon -runMode=console -projectPath="/test/kat/Mobile.prj" -reportFolder=./Reports/Mobile/Com/Sanity/ -reportFileName=report -retry=0 -retryFailedTestCases=false -testSuitePath=“Test Suites/Mobile/Com/Sanity” -browserType=“Chrome” --config -proxy.option=MANUAL_CONFIG -proxy.server.type=HTTP -proxy.server.address=“localhost” -proxy.server.port=“8080”

I bet, katalon is NOT causing OWASP ZAP to respond 502 Bad gateway.

Googling “OWASP ZAP proxy 502” gave me a lot of pages to read. For example,

It seems you need to look at how your network around your Linux box, as well as how your OWASP ZAP is configured.