How much appium version is compatible with katalon 7.1.0 xcode 12.0 và ios 13.2.2

i using appium version from 1.13.1 to 1.15.1 and katalon version 7.1.0 xcode versiion 12.0 và real device ios 13.2.2 but can not see device in devices list
I think because appium is not compatble with katalon version 7.1.0 but I don’t sure

Any ideal for solution is precious to me now

Thank you