Does the latest katalon Studio version support the xcode 10.1 and ios 12 on MAC


#1

Does the latest katalon Studio version support the xcode 10.1 and ios 12 on MAC machine?


#2

No, Katalon does not support Xcode 10.1 and iOS 12 as of now on MAC


#3

is there the plan to support the xcode 10.1 and iOS 12?


#4

there is Xcode new version version 11.0


#5

I can tell you that I have Katalon Studio 5.10.1 and Appium 1.8.1 on my machine with both Xcode 9.4.1 and 10.1 running side-by-side and I’m able to run Katalon tests. Here’s how it works for me:

  • Install Appium 1.8.1 via npm install -g appium@1.8.1
  • Install Katalon Studio 5.10.0 (latest)
  • Install Xcode10.1 from the App Store as your default version
  • Download Xcode9.4.1 from the Apple Developer Center: https://download.developer.apple.com/Developer_Tools/Xcode_9.4.1/Xcode_9.4.1.xip
  • Extract and install Xcode9.4.1 into your /Applications folder, choosing “Keep Both” when prompted to overwrite.
  • Name the Xcode9.4.1 application to Xcode9.4.1
  • Set the default version of Xcode to 10.1 via sudo xcode-select -s /Applications/Xcode.app/Contents/Developer
  • In Xcode 10.1, build the Appium WebDriverAgent project (located in /Users/<yourhome>/.nvm/versions/node/<nodeversion>/lib/node_modules/appium/node_modules/appium-xcuitest-driver )
    NOTE: You will need to do the following to get it to compile in Xcode10:
    • In Xcode, go to File->Project Settings and change the Build System to “Legacy Build System”
    • In the WebDriverAgentLib target, go to the Build Settings tab
    • Find “Other Linker Flags” and add -Wl,-U,"_OBJC_CLASS_$_XCElementSnapshot"
  • Do any development of your app in Xcode10.1
  • When ready to test, switch the default version of Xcode to 9.4.1 via sudo xcode-select -s /Applications/Xcode9.4.1.app/Contents/Developer (this is because Katalon Studio doesn’t support Xcode10 yet)
  • Open Katalon Studio
  • Run your tests

Hope this helps,

Chris


#6

Hello,

Despite your explanation I still have the error message.

I am developing my application with xCode 10.1 and swift 4.


#7

Hi @Dino,

What’s the error message you’re seeing? You can also build the WebDriverAgent project using Xcode9.4.1, instead, then you shouldn’t have to add -Wl,-U,"_OBJC_CLASS_$_XCElementSnapshot".

I should note that because Katalon Studio doesn’t support Xcode10, yet, you can’t test on an iOS12 simulator - you’ll still need to use an iOS11.4 or lower simulator to run your tests.

– Chris


#8

I tried everything … even by downloading version 11.2 on xCode 10.1 simulators …


#9

Hi @Dino

That’s an interesting error because the UDID is supposed to be something like 0A882FFF-10CC-43C2-896E-E83CA5DBE295, not 9.7-inch. Could you share a screenshot of what your Katalon Studio’s Project settings are? Namely the Project Settings->Desired Capabilities->Mobile->iOS screen? Mine looks something like this at the top:

Here are the steps that worked for me to create an app in Xcode 10 but test in Katalon Studio (Xcode 9.4.1):

  • Install both Xcode 9.4.1 and Xcode 10 (make sure you say “Keep Both” or “Rename” when installing the 2nd version)
  • Switch to Xcode 10 to do any development of the app you want to test using sudo xcode-select -s /Applications/Xcode.app/Contents/Developer (assuming the Xcode 10 app is named Xcode.app) NOTE: Make sure the Deployment Target is iOS 11.4 or less.
  • Build the app in Xcode 10, making note of where the DerivedData directory is and the resulting .app file. You can change this location in Xcode->Preferences->Locations. Here is how mine is set up:

  • This will create an app file located at MyProject/DerivedData/Build/Products/Development-iphonesimulator\MyProject.app
  • Switch to Xcode 9.4.1 in the command line using sudo xcode-select -s /Applications/Xcode_9.4.1.app/Contents/Developer
  • If you haven’t already, build the Appium WebDriverAgent project using Xcode 9.4.1
  • Start the Simulators app (this should be the one for Xcode 9.4.1)
  • Start the simulator for an iOS 11.4 device you want to test on
  • Drag the MyProject.app file from above into the simulator. This effectively installs it.
  • In Katalon Studio, make sure you start your test using false for the 2nd argument to MobileBuiltInKeywords.startApplication. This makes sure that the app won’t get removed and reinstalled every time. NOTE: You could also just point your test to the MyProject.app file.
  • Run your Katalon Studio tests

Hope this helps,

Chris


Xcode 10 Not Supported in Katalon 5.7.1
#10

hi @Chris_Trevarthen,

Thank you for your explanations. I managed to get around my problem by simply switching from iPad (iPad Air 2). However, he can not run my .app in the simulator. He first installs WebDriverAgent and then the app but it crashes on startup. He tries to restart it a second time but it also crashes.


#11

Hi @Dino

Can you please verify that the WebDriverAgent project builds OK through Xcode and that you don’t see any errors in the Signing section?

You should see the targets looking like this:

You might need to change the Build Settings for WebDriverAgentRunner to set the Product Bundle Identifier to a bundle id for your company:

– Chris


#12

As an alternative solution. I’m not sure i’d recommend it for everything or everyone because its uses a beta version, but it you absolutely have to run xcode 10 with Katalon you can upgrade appium to ver 1.8.2beta. That version supports the latest xcode versioning scheme, but is still compatible with the way Katalon interacts with appium. I haven’t had any major issues with this setup running ios tests. There is a bug with some of the iPad simulators. The tooling expects the UDID to be in the second set of “()” however that is not the case with some of the iPads, so you get the error you saw “Unknown device or simulator UDID:”


#13

hi,

The problem is resolved. I had a version problem. I had to install version 11.3 in the simulators because version 11.4 was not compatible with Katalon. I also deleted version 11.4 of the simulators to be on executing the right version in Katalon. Information is also important before installing the application directly into the simulator (drag and drop). Otherwise it did not work either. I hope this post will help some while waiting for the update of the Katalon team with the compatibility of xCode 10 & IOS 12.