File in Test Suite does not display in Katalon Studio

Hi, I am new Katalon Studio and I’m performing some API automation tests. I pulled a latest build in the studio and I see that the Test Suite field that was originally having a test file is not displaying anymore.
I check the Test Suite folder and I see that file but not on Katalon Studio.We had to go about and change the name of the file and only then I can see the file on pull. Can anyone tell me how to resolve it if it happens again.

hi,

use git or github to save your project

Which version of KS?

Sounds like a caching/refresh problem. When this happens again, try refreshing the project.

image

You could also try cleaning your project:

I used git hub to save my project. The pull is successful too. The changes are reflected to every other folder except Test Suites.

The Katalon studio version is :7.2.1
I did try with ‘Refresh’ but it’s still the same.

@krithika.shetty

Please read the post by Russ again. He suggested one more method to try. Have you tried it?

You could also try cleaning your project.
Close Katalon, then delete the following two folders and two files from the project folder.

Hi , i too am facing the same issue. Have you got this resolved?

Hi …

The suggestion given by deleting & refreshing some folders, did not helped me.
If any chance .meta in your test suites gets pushed to your GitHub, you might experience this.
Delete the .meta file and verify the test suites ,all your file files will be accessible from Katalon.
Its my way of clearing this issue