Devops licence changes - Azure Releases


Up until yesterday we could run a release against our environments using our 1 katalon devops licence and our 4 environments would all run successfully.

However now 1 is starting and the other 3 fail due to an error around the licence quota:

Katalon TestOps: Unexpected response, URL:, Status: 400, Response: {“timestamp”:“2020-12-10T08:55:02.839+0000”,“status”:400,“error”:“Bad Request”,“message”:“License quota exceeded.”,“trace”:"com.katalon.kit.exception.KaBadRequestException: License quota exceeded.\n\tat

If this means we can only run 1 at a time I’m confused as to how this ever worked as this is what we did as part of our proof of concept and the reason we only thought we needed 1 devops licence to successfully execute katalon tests after a deploy.

Any help would be appreciated and feel free to ask for more information as this is kind of hard to explain when I don’t understand what could of changed.

P.s I’ve made no changes in the last few days to anything it’s just started happening itself


@christian Try from the license manager to delete the registered machine and start again I got this issue too and when I delete the registered machine and try again was working. For me, I got this issue for Katalon Runtime engine


Thanks for the reply.

I did try this earlier and then ran another deploy but the same issue happened again.

The first of the 4 retailers to build succeeded and the automation passed however the other 3 failed again with the quota exceeded error :frowning:

I’m confused by the fact if this is just because only 1 machine can run at a time how this ever worked.

I’ve checked the timestamps on previous builds and can confirm that previous tests across multiple machine ran at the same time.

Thanks again for the reply though :slight_smile:


Same issue happen to me. I only can run one test collection at the same time in a docker instance, trying to run more than one is returning the same message related to the license quota exceeded. Note that yesterday was working fine, and i was able to execute many collection at the same time. Also i delete the registered machine as suggested @costea.georgian89 but doesn’t work.
Any help or suggestion will be appreciated.

1 Like

Did you upgrade your Katalon Runtime Engine with the latest one? Try to update and maybe here will be a solution I am not sure.

Thanks for the replay.
I upgrade the katalon with the latest version 7.8.1, but still getting the issue.

@equinta But Katalon Runtime engine? Not Katalon Studio.


Yeah from what it sounds like to me they have changed something their end to do with moving from dev-ops licence to this new floating licence and are probably going to make us buy more licences.

Which is a bit crap as I’ve signed off a proof of concept presentation to my managers based on how this worked for the last 3 months and getting another 3+ licences purchased probably isn’t an option :frowning:

Is a issue because I use the same machine id and it returns me the License quota exceeded.

Now is working from my side. Check after the test case is finished if the license is released. @christian @equinta

@ThanhTo Can you check this I saw in another post where you answer for the license issues but here is other specific test cases like my example I use the same machine id and I got the error message License quota exceeded and only I delete the machine Id from Katalon Runtime Engine - Katalon TestOps start to working again but yesterday I did the same thing. Thank you in advance!

@costea.georgian89, yes the license is released after finish the test collection. I’m using the TestOps floating license in a docker, same Machine Id. still having the issue.