Connection problems with SOAP testing: Connection Refused or wrong host


#1

Hi everyone,

I’m not being able to test a specific SOAP webservice using Katalon. I noticed instead of sending the request to the correc IP, it sends it to 0.0.0.0:2380 and I have no idea why.

Some facts:

  • I am behind a VPN, but I tried all the possible proxy configurations and the result is always connection refused
  • I tried another Katalon installation, in the same network where the service is (no VPN) but the result is the same
  • REST services work like a charm
  • The “Load from WSDL” command works
  • SOAP webservices from the JIRA demo project and other webservices like the calculator one work normally
  • The problematic request works in SoapUI, although I noticed when I create it from the WSDL, SoapUI creates the requests with the IP 0.0.0.0:2380, which I then have to replace with the correct URL base
  • Using Fiddler, I noticed SoapUI goes straight to the right URL, while Katalon tries to go to the 0.0.0.0:2380 one
  • The webservice is a Tibco one

Any help is appreciated. Thanks!

Request info.txt (1.0 KB)


#2

I just noticed the webservice I’m testing (from a Tibco system) returns that IP in the soap:address element. I still didn’t find out whether the provider of the service can change that to return the correct address. However, I would like to be able to change that address in Katalon, when needed, and it seems that’s not possible.


#3

After investigating and understanding the issue, I have created another specific topic for this.