Activate Katalon Studio


#1

This is a companion discussion topic for the original entry at https://docs.katalon.com/katalon-studio/docs/katalon-studio-activation-since-70.html

#2

hello,

I was not able to test Katalon enterprise as I did not achieve to activate it through my proxy.

First I tried to configure proxy (as in Katalon studio) :


, but it didnt’ work when I tried to activate :
image

Then I tried the link “Offline activation” with my machineId, but I only received another code (4f6325blablabla) which I do not know how to use in activation form (as apparently, the form wait for a file, not for a code):
image

Do you have a solution for me in order to try Katalon Enterprise ?


#3

Hi, I’ve been using Katalon Studio for free. Is this not possible with Katalon Studio 7?
It says “Please make sure your credentials are valid.” - I’m using the same credentials to login to the site

EDIT
Seems like it was an issue with my VPN access/restriction. I am now using the new version:smiley:


#4

hi,

after Katalon 7 version installation I have this problem (cannot set up integration with TestOps):


#5

+1
I am having the same issue.


#6

I’m having this issue also and I’m also unable to run my test suites in Jenkins because of the update.


#7

@aukse.zirgule @dave.horsey Please try this solution :


#8

@jpalmer You would need Katalon RE to run test suites in CI / CD

Katalon Runtime Engine (RE) : paid engine to execute tests in CI/CD infrastructures or via the command-line interface with options to activate offline. Compatible with KS and KSE.


#9

thanks, I was able to connect Testops to my acc! just one more question: is this configuration still valid?
docker:
- image: katalonstudio/katalon
steps:
- checkout
- run:
name: Execute Katalon Studio
command: katalonc-execute.sh -browserType=“Chrome” -retry=0 -statusDelay=15 -testSuitePath=“Test Suites/AllTests”


#10

Please add -apiKey option to the command.


#11

Hi, I am having the same issue. Could you please let me know what was the resolution. I have been struggling with this problem and am unable to find the root cause. I connect over VPN as well.


#12

Just to confirm, do you now have to pay for KSE to run in Jenkins?


#13

I reset my password on the official site and connected via a personal hotspot (or personal Wifi). Unfortunately I have not found a way to use it via the VPN, yet, other than keeping the application open when activating it first on a personal/public network (It asks for credentials on application start).


#14

As per @manpreet.mukkar answer above:
You have to now pay for KRE (Katalon Runtime Engine) if you use Katalon 7 which allows you to run the build commands in your CI/CD.
As far as I am aware KSE (Katalon Studio Enterprise) has extra features/tools & support for creating tests - which remains as a subscription - trial period is probably over.

We are still using KS 6.3.3 in our CI/CD as we can still run the tests - until we can justify paying for KRE. Support is said to be taken away in early 2020. Unfortunately, this means we don’t get the new Smart Wait feature in KS 7


#15

Thank you so much @jp.roussel. That worked for me :slight_smile:


#16

If you need to extend the trial please contact business@katalon.com. You can also use another work email (e.g. from colleagues).

Smart Wait is available in both editions.


#17

Are you referring to version 7 & version 6.3.3?


#18

Sorry I re-read you post. I thought what you said was about KS 7 edition (as in KS vs KSE). Now it seemed that you were talking about version 6.3.3 vs 7.0.0.


#19

Hi Team,

I am getting Please make sure your credentials are valid. message while activating my katalon Studio version.
Please look into this and let me know how to resolve this issue. Even though i have configured proxy as well

Thanks,
Neeraj Srivastava


#20

Hi

Has the issue been sorted? I have been getting the same error message while activating KS 7 version and looking for some solutions.

Thanks
Sangeetha