Workaround for the error: "Unable to schedule a test run in TestOps"

I wanted to post this FIX here just incase someone had the same issue.

WHAT:

You are not able to schedule test runs in Katalon test ops. In the “Script Repository” field there is a repo selected However it still does not work. the Object Name, ENV and Profiles are blank.

POSSIBLE FIX: This worked for us

In the script repository REMOVE the .git at the end of your repo name.

STEPS for FIX:

  1. Go to settings in Katalon TestOps
  2. Select Script Repositories
  3. Select EDIT on the top right
  4. Edit URL name ( remove .git) if yours has it
  5. SAVE
  6. Retest your scheduled run

WHEN we removed .git everything started to appear.

I will not take the credit for this fix as one of my colleagues was able to figure this out! I just wanted to advise the community.

If I posted this in the wring place, please forgive me.

3 Likes

Thanks for sharing!!

Thank you for much for posting this advise. It will help lots of others. I would like to move it for easier search.

1 Like

I would love to keep supporting this awesome community, It is my pleasure!

Yes please move for easier search !

1 Like