Why the "Capture Object" command (Spy & Record) suddenly stops working after a few seconds?

Hi everyone!

I’m diving into Katalon Studio to make a Chrome Testing Automation PoC for my company.

I’m building a first test case to automate the registration of a client in our company tool and I’ve found out that both recording the interactions with the website or “Spying” the web elements, the capture of the objects suddenly stops working after capturing some elements or interactions.

I start capturing the objects without a problem but suddenly after a small break to do something else, when I come back to the Katalon Spy/Record window the “Capture Object” command doesn’t work anymore… Despite that the elements keep being highlighted when I hover them and the “Verify and Highlight” button keeps highlighting the already captured elements inside the Chrome screen.

Some elements are included inside an iFrame but the command work fine until they suddenly don’t without notice.

I’ve seen that there were some problems if you are not using a US keyboard, si I’ve changed the “Capture Object” command Hotkey (Alt+A) but the result is the same… It works for some time and then suddenly stops working from then on. I’ve tried also using the “Right click + Capture Object” command but the result is the same.

I’m not sure if the problem happens after:

  • A few seconds pass without activity.
  • Changing focus outside Katalon and coming back to keep capturing objects or recording steps after a while.

I can bypass the problem by opening a new Spy/Record window every time the previous one stops working, but this ruins the user experience and make the process very tediuos and time consuming since I hace to open a new Chrome window every time and browse again until the same spot in the website to keep capturing more elements.

I’ve checked the forum but I haven’t found anything regarding this problem… Does this happens to anybody else? Can anybody help?

Thanks in advance! :sparkles:


How about if you click on a “blank” piece of the application, maybe like the title bar, to bring focus back to the application itself and then try to use the Spy after that and see if it starts working again.

1 Like


I’ve tried clicking on different blank pieces of the application again but the problem is still happening… :frowning:

I don’t know if this may help but I’m using:

  • Laptop: DELL Vostro 3520
  • OS: Windows 11 Pro 22H2 (64 bits)
  • OS Version: 22621.2715
  • I Record and Capture the Objects in the Browser: Google Chrome
  • Browser version: 120.0.6099.110 (Official compilation) (64 bits)
1 Like