Why are reports not sent to TestOps when running KRE via Jenkins?

I am running Katalon Studio 9.4.0.

The project is configured to automatically upload the test report after the suite finishes running.

I have successfully created a Katalon job which uses the Katalon plugin in Jenkins v2.45

When I run the job, it doesn’t upload the execution report to TestOps. When I run via KSE, it uploads the report.

Here’s a screenshot showing the project config.

I’ve attached the console output.

Jenkins-console-log.txt (21.4 KB)

1 Like

Hi there,

Thank you very much for your topic. Please note that it may take a little while before a member of our community or from Katalon team responds to you.

Thanks!

Hi,

Incase the test reports fail to update on TestOps automatically, you can try to upload them manually with the guide here: Upload JUnit and Katalon Studio reports to TestOps manually | Katalon Docs.

Thanks but I am trying to remove the dependency on an operator having to complete a manual step after running the test suite in Jenkins.

2 Likes