Website doesn't load properly when using Chrome on a docker container

I have a bunch of tests that are running locally but now its time to use docker instead using chrome.

On most tests there’s no problem, but the tests where I need to go to a website fail when loading the site.

The container is created and everything seems to be ok. The website opens perfectly on my computer but on the container it doesn’t load if I use Chrome.
If I use firefox (eg) it loads ok, but there are some other steps that don’t work properly so I want to maintain Chrome.

Do you have any idea what can I change?

The website is: and here’s a picture of the failed step on docker

1 Like

Hi @simao.oliveira,

Please share console log details

Hi @duyluong
Where can I find them?
But basically, the test fails in the next step (unable to click on object), even if I make a step to wait for page load, that step passes but the page continues the same (with the green loading circle).

are those the kind of logs that you asked for?

Caused by: org.openqa.selenium.ElementClickInterceptedException: element click intercepted: Element <a class="nav-link dropdown-toggle dropdown field-navigationtitle" data-toggle="dropdown">...</a> is not clickable at point (850, 99). Other element would receive the click: <div class="component image loading-spinner-overlay" id="js-vue-loading-spinner">...</div>
  (Session info: chrome=119.0.6045.199)
Build info: version: '3.141.59', revision: 'e82be7d358', time: '2018-11-14T08:25:53'
System info: host: 'bebfd2409d33', ip: '', 'Linux', os.arch: 'amd64', os.version: '', java.version: '17.0.9'
Driver info: com.kms.katalon.selenium.driver.CChromeDriver
Capabilities {acceptInsecureCerts: false, browserName: chrome, browserVersion: 119.0.6045.199, chrome: {chromedriverVersion: 119.0.6045.105 (38c72552c5e..., userDataDir: /tmp/.org.chromium.Chromium...}, fedcm:accounts: true, goog:chromeOptions: {debuggerAddress: localhost:34035}, javascriptEnabled: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: LINUX, platformName: LINUX, proxy: Proxy(), setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify, webauthn:extension:credBlob: true, webauthn:extension:largeBlob: true, webauthn:extension:minPinLength: true, webauthn:extension:prf: true, webauthn:virtualAuthenticators: true}

The OS is Linux 64bit
Katalon version:
Chrome version: 119 with those arguments [–no-sandbox, --disable-gpu, --incognito, --disable-dev-shm-usage, --headless=new] that I’ve tried to put to make it work.

I’ve also tried with katalon version and chrome 116 but the behaviour is the same.

Hope this helps.

Thanks in advance

anyone has any idea on how I can pass this issue?

Can you show us the error log for this situation. If you have been using Katalon for some time, then can you spend a moment and just cut out the appropriate area (think that if you don’t spend some time, why should we!!!)


The situation only occurs on a docker container, that beeing said, I have no access to Katalon Studio, thus, no access to that error log. Is it possible to have access to that error log when using katalon runtime engine?