Docker chrome and chromedriver incompatibility issues

I have added a command in my dockerfile so that my docker use the latest chromedriver but it does not update the chrome the docker is using. How to make docker use compatible chrome and chromedrivers. This issue is making my browser to not open and thus all tests failing. I even installed the latest chrome in the dockerfile but still docker is running old chrome version.

I am using 7.6.6 and in the docker my chrome version is staying to 84 while chrome driver version is 85.
Is there a way i can make the chrome version be 85 as well as or at least compatible with the latest one.
I am not able to understand why the chrome is not updating.

If someone needs any other info please do let me know.


Hi @anuradha,
In your command, please add the argument --config -webui.autoUpdateDrivers=true. This will help auto update web driver to a proper one.

Hi @huynguyen , i have added this already. My dockerfile is as follows:
version: “2”
build: .
container_name: katalon

user: 1000:1000

  - network
  base_URL: "xxxx"
  - .:/katalon/katalon/source
command: bash -c 'apt-get install tree -y && tree -L 3 /katalon/katalon/source/Include/&& rm /katalon/katalon/source/Include/drivers/chromedriver_linux64/chromedriver || true && mkdir -p /katalon/katalon/source/Include/drivers/chromedriver_linux64/ && unzip /tmp/chromedriver/ chromedriver -d /katalon/katalon/source/Include/drivers/chromedriver_linux64/ && -retry=0 -statusDelay=15 -testSuitePath="xxxxx" -executionProfile="xxxx" -browserType="Chrome" -apiKey="xxxx" -projectPath="/katalon/katalon/source/xxxxx.prj" --config -webui.autoUpdateDrivers=true'

external: true

Hi @anuradha,
Please go to to download a proper Chrome driver, then follow the instructions at to place it into your project. This driver will be used instead of the default one in Katalon Studio.

Hi @huynguyen, this is ok but what about when someone else clones the project and wants to run it in his machine?Should he also do the same steps for the test to run?


I am having this in the logs:
“This version of ChromeDriver only supports Chrome version 85” which from what i understand is my google chrome should be 85. If i have chrome 85 installed in my machine why the docker is using chrome 84, this i am not able to understand. Also the same tests when i run with KE or katalon it takes chrome version 85 but only with docker it is showing chrome 84 and failing my tests.

Hi @anuradha,
Docker container use the Chrome browser of its own. That means, the Chrome browser you use in your machine will not be used when you execute your test via Docker.

Thanks @huynguyen. Do you know any way how i can update chrome version to 85 in docker?
I tried installing the latest chrome but still it is using chrome 84.

Hi @anuradha,
Please use our latest Docker image.

Hi @huynguyen , i have pulled the latest docker images for katalon 7.7.2 and now i am getting the error:
Caused by: org.openqa.selenium.SessionNotCreatedException: session not created: This version of ChromeDriver only supports Chrome version 86
katalon | Current browser version is 85.0.4183.121 with binary path /usr/bin/google-chrome

How can i resolve this. I am a bit confused how docker is working with katalon images. Am i going to get these issues everytime i update the images?

Can someone please get back to me asap.

On top of that the latest chrome is 85 so we cannot update to 7.7.2 as we will get incompatibility issues.


Hi @anuradha,
With the latest docker image, please remove the command arguments --config -webui.autoUpdateDrivers=true and try again.