Unable to tap mobile object

Hi all,

I’m creating Android mobile app testing.

Mobile.tap(findTestObject('Object Repository/HSB/Login_button'), 30)
Above step shows it was success, but actually it doesn’t work (the button doesn’t be tapped)
Adding delay after tis step doesn’t work.

I also tried tapAndHold command, but it doesn’t work too.


macOS Catalina 10.15.6
Katalon Studio 7.6.2
Android emulator ‘system-images;android-29;default;x86’ ‘Nexus 5’


any solution?

hmm… downgrading appium to 1.14.1 (from 1.18.0) seems to resolve this…

Anyway, it doesn’t seem to relate to Katalon. Close.

1 Like

Hi All, I am facing same issue, while trying to tap on button on android app,

I tried this,

Mobile.tap(findTestObject('TCL/button_object - ‘Text’), 0)

Also, tried to use tapAndHold method but it does not seems working

@mhlthkr
Hi, did you try my solution?

I didn’t try with more later version, but at least appium 1.14.1 works for me.

i am facing the same issue in iOS automation on real device how to solve this issue

Hello, I usually use the following workarounds… Do any of these seem like a solution?

  • Mobile.doubleTap
  • Mobile.tapAndHold
  • Mobile.tapAtPosition

what happen was there two objects with a same id so script cannot find a specific one

In the case of that pattern, I took the following approach

  1. get the x-coordinate of the object you want to tap (either with the Spy function or with Mobile.getElementLeftPosition)
  2. get the y-coordinate of another object at the same height as the object you want to tap.
top_position = Mobile.getElementTopPosition(findTestObject('Object Repository/HSB/label'), 5)
println top_position

Mobile.tapAtPosition(892, top_position)

This method cannot be used if there is not another object at the same height, but I hope this will spark some ideas.

Faced the same issue on iOS: tap (passes) but doesn’t actually tap.
The object has a unique automation ID.

Double Tap worked for me.