Tap action on mobile fails to activate button on mobile application

Hello everyone,

I was trying to create an automated test case for clicking on a Register button by using Katalon Studio’s recording functionality, but when I run my testcase the testcase passes while nothing seems to have happened (which means that the button wasn’t clicked according to my knowledge). The application can be seen on the right of the screenshot below (I am trying to simply make the automated test case click the bottom button).

The buttons look like this and a user would simply need to tap the Register button on their mobile device for this test case to succeed.
Login and register buttons

I have tried to use the delay function, which didn’t make a difference. I have also tried to use the tapAndHold function, but when using that function the testcase doesn’t pass anymore, which you can see below.
Test case failing when using tapAndHold

I personally think the issue might be that the number after the register button seems to change everytime (see the image below to see the placement where this number is found, I have seen the number become 2, 3, 4 and 5), which might make it unable to find the button. This does seem weird to me though, because that should make the Mobile.tap function fail.
Code snippet weird number

Being able to make an automated test case click a button is important in order for me to continue with my work, so I would appreciate it if anyone can help me to solve this problem. I can provide more information if necessary.

This problem didn’t seem to occur when trying out Katalon Studio with my physical mobile phone by using a simple test project that used some simple phone menu buttons which are similar to button that you’ll find in your phone’s settings.

I am using my physical mobile phone (Android) which is connected to my laptop by a USB cable.
Appium version: 1.18.3
Katalon Studio: 7.7.2

@nick any luck to solve the above issue? I’m exactly the same problem, but when I tried the tap and hold, I can see the button changing as if it is taping and holding, but the tap button isn’t working.
did you find any solution?

@nick any update?