Unable to Open Project: Invalid Project Description


#1

After updating my local Katalon Studio and pushing to Bitbucket with changes made in the new version I am unable to open my project on any machine, and getting an error that project description is invalid. As soon as I pull from my Bitbucket server the project I am working in throws an resource exception in the following image:

ProjectIssue

I have attempted to delete the .project file and other temporary files to no avail. This is now happening on everyone of my machines that pulls from my main Bitbucket repo.

Thanks for any help! This issue is keeping my project at a standstill.


Unable to open project. Resource Exception
#2

Christian

You should probably attach your project file – Katalon devs will want to see it.

Is it okay if I close the other thread?


#3

I will attach my project file now thanks for the suggestion! That would be great close it, thank you!

Christian


#4

Attached is my current project file:

Text Form:
KatalonTests.txt (935 Bytes)


#5

The XML is valid.

Comparing your project to mine, I see yours is missing this block:

   <integratedEntity>
      <productName>qTest</productName>
      <type>PROJECT</type>
   </integratedEntity>

This appears IMMEDIATELY BENEATH the <tag></tag> element.

Warning: I am not an expert regarding this part of Katalon Studio.

Take a backup of your existing project file (.prj) and then try adding the block above. Then see if you can open the project.


#6

Thanks for the reply! Is this because you are utilizing qTest integrations? I have not added these to my project yet so perhaps that is why it is missing? Regardless I will give it a try on my backup machine, thanks for the suggestion!


#7

I haven’t knowingly done so, no. But again… I am not an expert in this area.


#8

Please try this:

  • Open the file .project under the root directory. The first lines should be
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
	<name>some%string%with%sign</name>
	<comment></comment>
	<projects>
	</projects>
  • Replace whatever inside the name tag with test. So it should become
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
	<name>test</name>
	<comment></comment>
	<projects>
	</projects>

#9

Thank you for the reply. I attempted the suggest fix of changing the .project file to reflect your suggestion but am getting the same error still. I also went ahead and added the qTest portion to my Project file as Russ suggested. I appreciate the help greatly!


#10

My apology for the trouble. Could you please share with us the two files: .project and <name>.prj?


#11

Also, please try deleting .project file and reopen the project.


#12

Thanks for the reply! I have attempted to delete my .project file but received the same error. I have now attached both files. The help is greatly appreciated!
KatalonTests.txt (819 Bytes)
project.txt (3.9 KB)


#13

Can anyone provide me with assistance on this issue? Thanks!