Unable to launch Katalon Studio trial

I installed a Katalon Studio trial several months ago and after installation it never worked. I recently dowloaded an updated version of the trial hoping the issues would be resolved but they are not. When ever I launch Katalon Studio, I see a message like this:
image
The log reads as follows, but is far longer (90K+ characters) than will fit in a post on this forum.
This application remains untestable. I don’t understand how and the installation procedure should be any harder than installing a regular Mac app.

These are the last 100 lines of the log file which presumably contain the error.

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.718
!MESSAGE Could not install bundle plugins/org.apache.commons.codec_1.7.0.jar A bundle is already installed with the name “org.apache.commons.codec” and version “1.7.0”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.722
!MESSAGE Could not install bundle plugins/org.codehaus.groovy.eclipse.refactoring_2.9.2.xx-201611170128-e46.jar A bundle is already installed with the name “org.codehaus.groovy.eclipse.refactoring” and version “2.9.2.xx-201611170128-e46”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.724
!MESSAGE Could not install bundle plugins/com.fasterxml.jackson.dataformat.jackson-dataformat-xml_2.9.1.jar A bundle is already installed with the name “com.fasterxml.jackson.dataformat.jackson-dataformat-xml” and version “2.9.1”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.727
!MESSAGE Could not install bundle plugins/org.w3c.dom.events_3.0.0.draft20060413_v201105210656.jar A bundle is already installed with the name “org.w3c.dom.events” and version “3.0.0.draft20060413_v201105210656”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.729
!MESSAGE Could not install bundle plugins/com.kms.katalon.core.webservice_1.0.0.201908270734.jar A bundle is already installed with the name “com.kms.katalon.core.webservice” and version “1.0.0.201908270734”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.734
!MESSAGE Could not install bundle plugins/org.eclipse.core.filebuffers_3.6.0.v20160503-1849.jar A bundle is already installed with the name “org.eclipse.core.filebuffers” and version “3.6.0.v20160503-1849”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.736
!MESSAGE Could not install bundle plugins/com.kms.katalon.support.testing.katserver_1.0.0.201908270734.jar A bundle is already installed with the name “com.kms.katalon.support.testing.katserver” and version “1.0.0.201908270734”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.739
!MESSAGE Could not install bundle plugins/org.eclipse.e4.ui.model.workbench_1.2.0.v20160229-1459.jar A bundle is already installed with the name “org.eclipse.e4.ui.model.workbench” and version “1.2.0.v20160229-1459”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.743
!MESSAGE Could not install bundle plugins/org.eclipse.swt.cocoa.macosx.x86_64_3.105.3.v20170228-0512.jar A bundle is already installed with the name “org.eclipse.swt.cocoa.macosx.x86_64” and version “3.105.3.v20170228-0512”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.746
!MESSAGE Could not install bundle plugins/org.codehaus.groovy.eclipse.ui_2.9.2.xx-201611170128-e46.jar A bundle is already installed with the name “org.codehaus.groovy.eclipse.ui” and version “2.9.2.xx-201611170128-e46”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.748
!MESSAGE Could not install bundle plugins/com.kms.katalon.util_1.0.0.201908270734.jar A bundle is already installed with the name “com.kms.katalon.util” and version “1.0.0.201908270734”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.750
!MESSAGE Could not install bundle plugins/com.kms.katalon.integration.jira_1.0.0.201908270734.jar A bundle is already installed with the name “com.kms.katalon.integration.jira” and version “1.0.0.201908270734”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.752
!MESSAGE Could not install bundle plugins/org.greenrobot.eventbus_3.1.1.jar A bundle is already installed with the name “org.greenrobot.eventbus” and version “3.1.1”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.755
!MESSAGE Could not install bundle plugins/org.eclipse.core.databinding.observable_1.6.0.v20160511-1747.jar A bundle is already installed with the name “org.eclipse.core.databinding.observable” and version “1.6.0.v20160511-1747”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.757
!MESSAGE Could not install bundle plugins/com.kms.katalon.composer.preferences_1.0.0.201908270734.jar A bundle is already installed with the name “com.kms.katalon.composer.preferences” and version “1.0.0.201908270734”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.758
!MESSAGE Could not install bundle plugins/com.kms.katalon.composer.objectrepository_1.0.0.201908270734.jar A bundle is already installed with the name “com.kms.katalon.composer.objectrepository” and version “1.0.0.201908270734”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.760
!MESSAGE Could not install bundle plugins/com.kms.katalon.platform.internal_1.0.0.201908270734.jar A bundle is already installed with the name “com.kms.katalon.platform.internal” and version “1.0.0.201908270734”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.762
!MESSAGE Could not install bundle plugins/org.eclipse.compare_3.7.1.v20170103-1805.jar A bundle is already installed with the name “org.eclipse.compare” and version “3.7.1.v20170103-1805”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.764
!MESSAGE Could not install bundle plugins/com.mysql.jdbc_5.1.38.jar A bundle is already installed with the name “com.mysql.jdbc” and version “5.1.38”

!ENTRY org.eclipse.update.configurator 4 0 2019-11-10 15:31:28.765
!MESSAGE Could not install bundle plugins/javax.annotation_1.2.0.v201602091430.jar A bundle is already installed with the name “javax.annotation” and version “1.2.0.v201602091430”

!ENTRY org.eclipse.osgi 4 0 2019-11-10 15:31:30.111
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: The platform metadata area could not be written: /private/var/folders/j1/kxnsbb1x71j29zv2l21cj32446bpq5/T/AppTranslocation/F8A5CEE1-1EF7-4CDA-805C-8BEDBB15B8C4/d/Katalon Studio.app/Contents/MacOS/config/.metadata. By default the platform writes its content
under the current working directory when the platform is launched. Use the -data parameter to
specify a different content area for the platform.
at org.eclipse.core.internal.runtime.DataArea.assertLocationInitialized(DataArea.java:61)
at org.eclipse.core.internal.runtime.DataArea.getStateLocation(DataArea.java:129)
at org.eclipse.core.internal.preferences.InstancePreferences.getBaseLocation(InstancePreferences.java:44)
at org.eclipse.core.internal.preferences.InstancePreferences.initializeChildren(InstancePreferences.java:209)
at org.eclipse.core.internal.preferences.InstancePreferences.(InstancePreferences.java:59)
at org.eclipse.core.internal.preferences.InstancePreferences.internalCreate(InstancePreferences.java:220)
at org.eclipse.core.internal.preferences.EclipsePreferences.create(EclipsePreferences.java:352)
at org.eclipse.core.internal.preferences.EclipsePreferences.create(EclipsePreferences.java:340)
at org.eclipse.core.internal.preferences.PreferencesService.createNode(PreferencesService.java:391)
at org.eclipse.core.internal.preferences.RootPreferences.getChild(RootPreferences.java:60)
at org.eclipse.core.internal.preferences.RootPreferences.getNode(RootPreferences.java:95)
at org.eclipse.core.internal.preferences.RootPreferences.node(RootPreferences.java:84)
at org.eclipse.core.internal.preferences.AbstractScope.getNode(AbstractScope.java:38)
at org.eclipse.core.runtime.preferences.InstanceScope.getNode(InstanceScope.java:77)
at com.kms.katalon.preferences.internal.ScopedPreferenceStore.getStorePreferences(ScopedPreferenceStore.java:216)
at com.kms.katalon.preferences.internal.ScopedPreferenceStore.(ScopedPreferenceStore.java:117)
at com.kms.katalon.preferences.internal.PreferenceStoreManager.initialPreferenceStore(PreferenceStoreManager.java:25)
at com.kms.katalon.preferences.internal.PreferenceStoreManager.getPreferenceStore(PreferenceStoreManager.java:21)
at com.kms.katalon.preferences.internal.PreferenceStoreManager.getPreferenceStore(PreferenceStoreManager.java:14)
at com.kms.katalon.util.ApplicationSession.getStore(ApplicationSession.java:47)
at com.kms.katalon.util.ApplicationSession.clean(ApplicationSession.java:16)
at com.kms.katalon.core.application.Application.preRunInit(Application.java:114)
at com.kms.katalon.core.application.Application.start(Application.java:60)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

You can zip it.

Hi @tremw

Where is your Katalon Studio located ? Please try to move Katalon Studio into Application folder and open it to see if it works.

Yes, the application is in the the Applications folder.
Here’s the .zipped log file from yesterday.
1573417885661.log.zip (9.7 KB)

Just bumping this issue. I’d really like to be able to evaluate this product. Any ideas?

I get a lot of sales emails from Katalon now but not a lot of help trying to make the demo work. How can I find out if this will work for us if it doesn’t run? Surely I’m not the only person who has the issue… Help?

Moved to Bug Reports.