Unable to commit and push to git via Katalon Studio


I am facing an issue currently. The commit and push button is greyed out (disabled) when I try to commit to gitlab via Katalon Studio. I am able to fetch and pull successfully in Katalon Studio. Kindly let me know how to resolve this issue.
I am using Katalon Version 8.5.5
I was able to successfully commit few days back. No changes made in setting of Katalon-Gitlab integration.

Hi @swarnasundary.peruma, Maybe try logging out of Katalon Studio and then back in again. This worked for me in the past. Good luck.

1 Like

ya…tried that… but no luck

Hi @pwarnasundary.perum, assuming you are using Windows I would close Katalon and then use file explorer to make a copy/archive of your project folder then delete the .cache and .git folders (you may need to unhide the .git folder) from your project folder. Afterwards start Katalon and re-share the project. You will need to do a new commit to rebuild your git folder.

Thank you so much for the response… would definitely try and update here. Yes, I am using Windows.