Trying to capture objects from the Office suite of applications

Hi I’m having problems capturing any objects when writing tests using the windows recorder (not the native one). The recorder, for the most part, can launch all the applications within the Microsoft Office suite except for word which is hit and miss with capturing objects. Not sure why.

Once it has launched however and I have selected actions to create a new book/document the windows recorder will not capture objects. So, to be clear it is still only the one window/form but just changed to the new document. In task manager this new doc being created is a child element of the MS Word or Excel process (in case this affects the switch to tile label).

At this point I cannot capture any controls on the new document even though the application has navigated correctly. I have tried:

  1. To switch to window tile (with the title of the new doc).
  2. Tried to switch to application (itself).
  3. Tried switch to desktop, then back again

and none of these has worked to capture the objects. What am I missing or is there a work around to force a focus or something similar. Many thanks in advance.

katalon version: 8.1.0
Build: 208