Test failure when suite launches automatically

I’ve been running my test suite automatically (using task scheduler) for years now, and recently the tests started failing every time. However, when I go back in and launch the test suite manually it works just fine. Is there something that recently changed? If so, do I need to update how I launch my test suite?

Thank you!

What are the failures? Anything “common” among them?

Unable to open browser with url: '' (Root cause: com.kms.katalon.core.exception.StepFailedException: Unable to open browser with url: ''
	at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:64)
	at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:26)
	at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.openBrowser(OpenBrowserKeyword.groovy:81)
	at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.execute(OpenBrowserKeyword.groovy:67)
	at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:56)
	at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.openBrowser(WebUiBuiltInKeywords.groovy:60)
	at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$openBrowser.call(Unknown Source)
	at duplicate checking - author CC.run(duplicate checking - author CC:20)
	at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)
	at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)
	at com.kms.katalon.core.main.TestCaseExecutor.runScript(TestCaseExecutor.java:331)
	at com.kms.katalon.core.main.TestCaseExecutor.doExecute(TestCaseExecutor.java:322)
	at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(TestCaseExecutor.java:301)
	at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(TestCaseExecutor.java:293)
	at com.kms.katalon.core.main.TestCaseExecutor.execute(TestCaseExecutor.java:227)
	at com.kms.katalon.core.main.TestSuiteExecutor.accessTestCaseMainPhase(TestSuiteExecutor.java:129)
	at com.kms.katalon.core.main.TestSuiteExecutor.accessTestSuiteMainPhase(TestSuiteExecutor.java:112)
	at com.kms.katalon.core.main.TestSuiteExecutor.execute(TestSuiteExecutor.java:81)
	at com.kms.katalon.core.main.TestCaseMain.startTestSuite(TestCaseMain.java:157)
	at com.kms.katalon.core.main.TestCaseMain$startTestSuite$0.call(Unknown Source)
	at TempTestSuite1632682861623.run(TempTestSuite1632682861623.groovy:35)
Caused by: org.openqa.selenium.SessionNotCreatedException: session not created
from timeout: Timed out receiving message from renderer: 600.000

Essentially, the test is timing out instead of even opening the browser/loading the page.

Just wondering, do you think this could be a time-of-day problem? What’s the difference between a suite-run and a by-hand run?

I tried scheduling for different times of day and had the same issue.

The key question is - what’s the difference? Are you retesting on the same machine with the same browser using the same suite code?

All other factors are the same, nothing has changed except that one day a few weeks ago it just stopped working.

Try this - if it fails, we’ll move this to bug reports (they’ll want to see a full log report).

  1. Setup a suite to start ten minutes from now.
  2. Run a few tests by hand, prove they’re working
  3. Wait for the suite to run.

Report back with your results (include browser version, Katalon version, and anything else you can think of that might help).

Thanks - I’ve got the suite running now and will report back when it’s done.

I had full failure again as before.

Katalon version: 6.0.6
Browser: Windows server 2012 R2 standard
Launched about 10am PST

Again - until about the beginning of the month, everything worked fine and then it started failing. I was already able to rule out any environmental issues on my end.

  1. Which browser do you use?
  2. Which version of the browser do you use now?
  3. Is the browser upgraded recently – at the beginning of the month – regardless manually or automatically?
  4. Or is the browser’s version frozen at an old one for years?

Google Chrome, version 93.0.4577.82. I do not have information as to whether or not it was recently upgraded.

This is the current (newest) version of Chrome at 28 Sep 2021.

Then you have to use the newest version of “Chrome Driver”. Have you updated the Chrome Driver module in Katalon Studio? See the following for how to:

Update a WebDriver

From the main toolbar, select Tools > Update WebDrivers > select a browser in the drop-down list.

I am not able to update my Katalon version, I presently am running 6.0.6.

Oh - I just updated and apparently doing that causes all files to be lost. So I have to go recreate that now I guess. It looks like this has been a known bug for a long time?

I don’t know of any version of KS that deliberately wipes a project folder.

Did you do “Install and Re-launch” on Windows machine ? as documented in


I have a doubt about “Install and Re-launch”. Years ago, I did it once and got the installed Katalon Studio corrupted. Since then, I never follow it. I never do “Install and Re-launch”.

(Forgive me, I am not 100% sure that “Install and Re-launch” is problematic. I am not a Katalon Developer. I have no intension to do full debug over KS product)

I always stop Katalon Studio before updating it. Then I would delete the old installation directory, recreate the directory where I install the new version of KS into, and start it. Yes, I have to do all setups again. But I always do clean-install.

Why I do not trust “Install and Re-launch”? — I have a reason. See

the Eclipse IDE’s README document writes;

Platform - Install/Update

Manually installing features and plug-ins on a FAT file system (Windows only)

When features and plug-ins are manually installed on top of an Eclipse-based product install located on a FAT file system that has already been run at least once, the product must be explicitly restarted with -clean. That is,

eclipse.exe -clean

I suppose that “Install and Re-launch” process does not explicitly restart Katalon Studio with “-clean”. Therefore “Install and Re-lauch” leaves the running instance of Katalon Studio as a mixed modules of the previous version and the new version, that results a total mess.

c/c @jass Am I right?

Deleting the folder where the previous version of Katalon Studio + recreating a new folder + installing the new version there; this procedure has the same effect as eclipse.exe -clean.

I guess, you saw the “Test Explorer” pane in Katalon Studio GUI showed an empty tree — no folders, no files.

However, if you looked into the project folder using Windows Explorer or some editors (I mean, not by Katalon Studio) then, I guess, you had found the folders and the files were still there.

Your Katalon Studio (restarted without --clean) got unable to read the project folder. In short, it is not operational any longer. You need to do a clean install.

You have 2 instances of Katalon Studio. One is KRE schedule by task scheduler, which is failing now. Another one is KSE which you operated manually and running OK. Possibly you have upgraded them each though different way of operations. I guess, you haven’t done -clean for your KRE, and it still has the cache on FAT file system messy.

Hi @cwilliams,

Please refer to my answer here: