Runtime Engine on trial behind proxy

Hi,

I am trying to execute the Runtime Engine with a trial license (business email, remains 20+ days on trial) behind a corporate proxy but online activation keeps failing.

Edit: theses proxy settings are working for Katalon Studio online activation.

Thanks.

Manual proxy proxy cli options are setup as follows:

katalonc -noSplash -runMode=console -projectPath=“C:\workspace\myproject.prj” -retry=0 -testSuitePath=“Test Suites/My TestSuite” -executionProfile=“default” -browserType=“Chrome” -apiKey="***" --config -proxy-option=MANUAL_CONFIG -proxy.server.type=HTTP -proxy.server.adress="" -proxy.server.port=“8080” -proxy.username="" -proxy.password=""

Runtime logs:

Fri Dec 13 12:00:58 CET 2019
com.kms.katalon.integration.analytics.exceptions.AnalyticsApiExeception: org.apache.http.conn.HttpHostConnectException: Connect to analytics.katalon.com:443 [analytics.katalon.com/54.210.241.240, analytics.katalon.com/54.173.6.241] failed: Connection timed out: connect
at com.kms.katalon.integration.analytics.exceptions.AnalyticsApiExeception.wrap(AnalyticsApiExeception.java:23)
at com.kms.katalon.integration.analytics.providers.AnalyticsApiProvider.testConnection(AnalyticsApiProvider.java:103)
at com.kms.katalon.integration.analytics.providers.TestOpsFeatureActivatorImpl.testConnection(TestOpsFeatureActivatorImpl.java:109)
at com.kms.katalon.execution.console.ConsoleMain.launch(ConsoleMain.java:205)
at com.kms.katalon.console.application.Application.runConsole(Application.java:71)
at com.kms.katalon.core.application.Application.runConsole(Application.java:98)
at com.kms.katalon.core.application.Application.start(Application.java:73)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: org.apache.http.conn.HttpHostConnectException: Connect to analytics.katalon.com:443 [analytics.katalon.com/54.210.241.240, analytics.katalon.com/54.173.6.241] failed: Connection timed out: connect
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:151)
at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(PoolingHttpClientConnectionManager.java:353)
at org.apache.http.impl.execchain.MainClientExec.establishRoute(MainClientExec.java:380)
at org.apache.http.impl.execchain.MainClientExec.execute(MainClientExec.java:236)
at org.apache.http.impl.execchain.ProtocolExec.execute(ProtocolExec.java:184)
at org.apache.http.impl.execchain.RetryExec.execute(RetryExec.java:88)
at org.apache.http.impl.execchain.RedirectExec.execute(RedirectExec.java:110)
at org.apache.http.impl.client.InternalHttpClient.doExecute(InternalHttpClient.java:184)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:82)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:107)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:55)
at com.kms.katalon.integration.analytics.providers.AnalyticsApiProvider.executeRequest(AnalyticsApiProvider.java:504)
at com.kms.katalon.integration.analytics.providers.AnalyticsApiProvider.executeRequest(AnalyticsApiProvider.java:533)
at com.kms.katalon.integration.analytics.providers.AnalyticsApiProvider.testConnection(AnalyticsApiProvider.java:100)
… 17 more
Caused by: java.net.ConnectException: Connection timed out: connect
at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
at org.apache.http.conn.ssl.SSLConnectionSocketFactory.connectSocket(SSLConnectionSocketFactory.java:337)
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:134)
… 30 more

Cannot connect to Katalon TestOps server. Please check your Internet connection and try again.
All launchers terminated

This must be a mistake.

Good catch @kazurayam, thanks !

Unfortunately it does not change the result and the logs are still the same

Corrected arguments as parsed by the engine:

-runMode=console -projectPath=C:\workspace\myproject.prj -retry=0 -testSuitePath=Test Suites/My TestSuite -executionProfile=default -browserType=Chrome -apiKey=****** --config -proxy-option=MANUAL_CONFIG -proxy.server.type=HTTP -proxy.server.address=****** -proxy.server.port=8080 -proxy.username=****** -proxy.password=******

Previously you had this:

This time you have this:

Are you sure?

yes sorry for the inconsistency.
I have simply redacted sensible informations. Address, username and password contains my proxy settings, the same which are working fine inside Katalon Studio when it is activating itself at startup.

Hi @bredda

Did you type proxy command manually, or copied-pasted form another text editor ? Please confirm that no special characters (such as weird quotes) are presented and that your strings (port, address) are surrounded by the double quotes.

Hi @ThanhTo,

Thaks a lot ! Indeed I copied-pasted credentials from notepad, when typing it manually activation is ok.

Thanks again !

1 Like