"Record Web" is NOT recording all objects:

Katalon Studio

Version: 5.6.0

Build: 1

01. Open Katalon

02. Click File > Open Project

03. Open any existing project

04. Click File > New Test Cases

TestCaseName= Check Record Web button

05. Click “OK”

06. Click the “Record Web” icon

URL= https://katalon-demo-cura.herokuapp.com/

07. Click the “Start recording” icon (I used Chrome)

https://katalon-demo-cura.herokuapp.com/ page loads

08. Click the “Make Appointment” button

09. Input the Username

10. Input the Password

11. Click Login button

12. Click OK button in the “Web Recorder”

13. Click “New Folder” button in the “Web Recorder”

New Folder= Kat_demo

14. Click “OK” button to save objects

Notice the “Make Appointment” button object was not recorded
Should it not be recorded below the Navigate to Url object?
*If you continue on recording other objects are not being recorded as well.

recordWeb.png

I am currently using Version 5.6.0 Build 1 (Katalon Studio). I am running into the same issue.

Web Recorder is not listing a script for all the buttons on a page. I was testing our web page and the login button will not record. I have tried using Chrome and Firefox and receive the same results. What is more confusing, I was able to record this step last week but had a problem with a different button. This week, i cannot record the logging in to our web site.

Any information to resolve this issue would be greatly appreciated.

Adding log file for my issue posted above.

Thanks,
Dave

.log

Hi Dave,
Please share with us some information:
- What is your Chrome browser version?
- Did you start recording New Browser mode or Active Browser mode?
- In case you chose Active Browser mode, please remove Katalon Utility (deprecated) and install fresh new Katalon Recorder 3.6.3 (https://chrome.google.com/webstore/detail/katalon-recorder-selenium/ljdobmomdgdljniojadhoplhkpialdid?utm_source=chrome-ntp-icon)

Hi Duyluong,
Thanks for looking into my issue:

My Configuration:

  1. Chrome browser version

-Google Chrome is up to date

-Version 68.0.3440.106 (Official Build) (64-bit)

  1. Katalon Recorder

-Removed Katalon Recorder from Chrome

-Reinstalled Katalon Recorder 3.6.3 into Chrome

  1. Started recording using Chrome in ‘New Browsers’ mode & ‘Active Browsers’ mode

Test steps:

1. Downloaded & did a fresh install of “Katalon_Studio_Windows_64-5.6.0.zip”

to new Katalon_Studio_Windows_64-5.6.0 folder

2. Opened Katalon

3. Select ‘File’ > ‘New’ > ‘Test Case’ > ‘OK’

4. Click ‘Record Web’

5. Set URL= https://katalon-demo-cura.herokuapp.com/

6. Selected ‘New Browsers’ mode

7. Clicked ‘Start recording’

8. Clicked on ‘Make Appointment’ button

Web Recorder result:

1 Open Browser

2 Navigate

*Same issue is seen when ‘Active Browsers’ mode is used

**Note: If I use Katalon Studio Version: 5.4.1 Build: 1 recording works as expected.
**

RecordingIssue.png

1 Like

Same issue for me.

I have just ran into this issue as well :/.

Hi all,

Thanks for your information. In this case, the root causes are varied, so is anyone here can provide me a video showing your step-by-step in details when you observe this issue? Just want to know if additional actions are used you use when you interact with your browser.

Hi all,

The Katalon Team has released hotfixes addressing Record Web Utility issue in v5.6.1. The download links are included below. Please give it a try and let us know if it works!

If the issue still persists, feel free to follow up on this discussion.

One more thing, anyone who experienced this issue, please help to send object spy and recorder prefs file to info@katalon.com. This will help the development team further investigate the issue. Below is the location of the file:

Windows
config\.metadata\.plugins\org.eclipse.core.runtime\.settings\com.kms.katalon.composer.webui.objectspy.prefs

macOS
/Applications/Katalon Studio.app/Contents/MacOS/config/.metadata/.plugins/org.eclipse.core.runtime/.settings/com.kms.katalon.composer.webui.objectspy.prefs

Katalon Studio v5.6.1
http://download.katalon.com/5.6.1/Katalon_Studio.dmg
http://download.katalon.com/5.6.1/Katalon_Studio_Windows_64-5.6.1.zip
http://download.katalon.com/5.6.1/Katalon_Studio_Windows_32-5.6.1.zip

As always, thank you all for your continued support!

Best,
Liam

What do we do with http://download.katalon.com/5.6.1/Katalon_Studio.dmg
I installed http://download.katalon.com/5.6.1/Katalon_Studio_Windows_64-5.6.1.zip and am still seeing my issue as detalied above.

I just tested with 5.6.1 and the issue is still there. For me the click of one of the buttons I use does not get recorded.

Just tested https://katalon-demo-cura.herokuapp.com/ and pressing the make appointment button does not register. Also within the login screen, pressing the login button does not register.

Dave Evers said:

What do we do with http://download.katalon.com/5.6.1/Katalon_Studio.dmg
I installed http://download.katalon.com/5.6.1/Katalon_Studio_Windows_64-5.6.1.zip and am still seeing my issue as detalied above.

Kareem Hutchinson said:

I just tested with 5.6.1 and the issue is still there. For me the click of one of the buttons I use does not get recorded.

Please help to send Katalon Studio logs again in this case.

FYI:
- .dmg file is used for macOS. If you use Windows, then please just ignore it.

Hi Liam,

Would it be possible to get a previous version of Katalon where the recording was working? ‘Katalon_Studio_Windows_64-5.0’ was working for me before updating to ‘Katalon_Studio_Windows_64-6.0’. Would it be possible to get a Katalon_Studio_Windows_64-5.0.zip?

It might even make sense that Kataon have an archive page of older versions so that user can roll-back installations that are not working after updates are released. This would ensure that users could continue working while solutions were found.

Dave Evers said:

Hi Liam,

Would it be possible to get a previous version of Katalon where the recording was working? ‘Katalon_Studio_Windows_64-5.0’ was working for me before updating to ‘Katalon_Studio_Windows_64-6.0’. Would it be possible to get a Katalon_Studio_Windows_64-5.0.zip? This would at least get me and maybe others back to where they can work until a solution is found.

Thanks for your information. Can you first help me to post Katalon Studio logs again from version 5.6.1 :)?

Do you mean the steps themselves or some specific log file?

I mean the whole log file in this folder:

Windows (\config\.metadata\.log)

MacOS (file:///Applications/Katalon%20Studio.app/Contents/MacOS/config/.metadata/.plugins/org.eclipse.ui.workbench/log)

Hi Vinh,

I have attached my test project and log file.

0816.log

TestProject.rar

This is my log as well.

BugTest.log

Dave Evers said:

Hi Liam,

Would it be possible to get a previous version of Katalon where the recording was working? ‘Katalon_Studio_Windows_64-5.0’ was working for me before updating to ‘Katalon_Studio_Windows_64-6.0’. Would it be possible to get a Katalon_Studio_Windows_64-5.0.zip?

It might even make sense that Kataon have an archive page of older versions so that user can roll-back installations that are not working after updates are released. This would ensure that users could continue working while solutions were found.

By the way, here are the links for version 5.5:

http://download.katalon.com/5.5.0/Katalon_Studio.dmg

http://download.katalon.com/5.5.0/Katalon_Studio_Windows_64-5.5.zip

http://download.katalon.com/5.5.0/Katalon_Studio_Windows_32-5.5.zip

Thanks :)! 5.5 is working as expected for me.