Web Recording completly broken in 5.6.0

Recording web in chrome is not working at all in Katalon 5.6.0.
It will only open browser and not record anything. This is true for both Active Browser recording and new browser instance recording. It is just completly broken.
I update Katalon because it prompts to do so, and I can not continue in my work. What a shame Katalon. I’m sorry, but you have the test software that you probably did not test before releasing.

1 Like

It seems to be working fine for me.

Working fine for me. Make sure to update Katalon Recorder to latest version first, otherwise please provide more details about your issue.

Working fine for me, Windows 10 Google Chrome 68

googlechromerecording.png

Clicking on chrome Record (active browser) makes everything than before - highlights stop, creates open browser: “” command, but it does not capture anything even tho I have Katalon Recorder as plugin on port 50000 set up for both correctly and everything. Update from lower version killed my Katalon studio. I will try to reinstall, but I hope I will then still have some of the preferences set up the same.
My chrome is up to date - Chrome 68 and Katalon Studio web recorder was working fine untill this update. So I know 100% that this update broke it for whatever reason.

So for Active Browser, please have your Katalon Recorder up to the latest version and try again. Somehow I can’t seem to reproduce your issue from my side

It seems like port 50000 was the issue. I have changed it to different one. I can not tell why 50000 does not work. I have also re-installed the app

I’m having this similar issue. I already check my chrome is version 68. I download a new copy of 5.6.0 rather than using the update. Same issue. I did find something weird the web recorder is using version 3.5.7 Katalon Automation recorder. On my chrome browser, it is using the new updated version 3.6.2. Where do you go to change the port 50000?

image.png

Vinh Nguyen said:

So for Active Browser, please have your Katalon Recorder up to the latest version and try again. Somehow I can’t seem to reproduce your issue from my side

How do I update the latest version from Active Browser? Look at my previous comment.

John Yi said:

Vinh Nguyen said:

So for Active Browser, please have your Katalon Recorder up to the latest version and try again. Somehow I can’t seem to reproduce your issue from my side

How do I update the latest version from Active Browser? Look at my previous comment.

Ah sorry my bad if you are using New mode then you don’t need to update Katalon Recorder. CAn you help to provide Katalon Studio logs? (please refer to this page http://forum.katalon.com/discussion/4405/read-this-first-before-reporting-an-issue-bug#latest how to retrieve Katalon Studio logs)

Vinh Nguyen said:

John Yi said:

Vinh Nguyen said:

So for Active Browser, please have your Katalon Recorder up to the latest version and try again. Somehow I can’t seem to reproduce your issue from my side

How do I update the latest version from Active Browser? Look at my previous comment.

Ah sorry my bad if you are using New mode then you don’t need to update Katalon Recorder. CAn you help to provide Katalon Studio logs? (please refer to this page http://forum.katalon.com/discussion/4405/read-this-first-before-reporting-an-issue-bug#latest how to retrieve Katalon Studio logs)

## OS (Windows 10)

## Katalon Studio Version (5.6.0)

## Katalon Studio logs:

Windows (\config\.metadata\.log):
.log attached

## Environment (for Web testing)

Browser (Chrome Version 68.0.3440.84 (Official Build) (64-bit))

## Steps to reproduce

1. click on Record Web

2. enter you URL for testing

3. Select Chrome browser

4. Perform your test on Active browser and notice steps are not recorded

## Expected Behavior

See steps recorded in Web Recorder other than open and close browser

## Actual Behavior

No steps recorded

## Screenshots / Videos
look at video for the issue

.log

Any Katalon representative help, please. It’s been a week!

I am seeing the same issue that I posted here:


See the .log file for details

Thanks,
Dave

Tomas Rehak said:

Recording web in chrome is not working at all in Katalon 5.6.0.
It will only open browser and not record anything. This is true for both Active Browser recording and new browser instance recording. It is just completly broken.
I update Katalon because it prompts to do so, and I can not continue in my work. What a shame Katalon. I’m sorry, but you have the test software that you probably did not test before releasing.

Hello,

Please make sure you reset your katalon Studio preferences and possibly set your project settings. I find even after I import settings, i still have to set some of my preferences. For example, I like to remove the ‘href’ and ‘src’ Test Design Web Locators so I can run across other URLs when testing.

I have several versions of Katalon Studio, as a just in case. You may want to do the same. However, the latest version (and other version) is working for me.

I am using windows 10 and chrome browser.

I have a directory structure similiar to the following:

C:\katalons\Katalon_Studio_Windows_64-5.4.2

C:\katalons\Katalon_Studio_Windows_64-5.4.x

C:\katalons\Katalon_Studio_Windows_64-5.6.0

the 5.4.x is a version I updated directly, rather than download into a separate directory.

So far, so good! Good Luck,

Stewart

Hi all,

The Katalon Team has released hotfixes addressing Record Web Utility issue in v5.6.1. The download links are included below. Please give it a try and let us know if it works!

If the issue still persists, feel free to follow up on this discussion.

One more thing, anyone who experienced this issue, please help to send object spy and recorder prefs file to info@katalon.com. This will help the development team further investigate the issue. Below is the location of the file:

Windows
config\.metadata\.plugins\org.eclipse.core.runtime\.settings\com.kms.katalon.composer.webui.objectspy.prefs

macOS
/Applications/Katalon Studio.app/Contents/MacOS/config/.metadata/.plugins/org.eclipse.core.runtime/.settings/com.kms.katalon.composer.webui.objectspy.prefs

Katalon Studio v5.6.1
http://download.katalon.com/5.6.1/Katalon_Studio.dmg
http://download.katalon.com/5.6.1/Katalon_Studio_Windows_64-5.6.1.zip
http://download.katalon.com/5.6.1/Katalon_Studio_Windows_32-5.6.1.zip

As always, thank you all for your continued support!

Best,
Liam

1 Like

Awesome 5.6.1 worked!

John Yi said:

Awesome 5.6.1 worked!

Hi John Yi,

Can you help to tell me which steps you’ve done from your side to see it is working for you? Please try with New browser as well on our UAT site: demoaut.katalon.com

Please also help to send me your used prefs as well:
Windows
config\.metadata\.plugins\org.eclipse.core.runtime\.settings\com.kms.katalon.composer.webui.objectspy.prefs

macOS
/Applications/Katalon Studio.app/Contents/MacOS/config/.metadata/.plugins/org.eclipse.core.runtime/.settings/com.kms.katalon.composer.webui.objectspy.prefs

Vinh Nguyen said:

John Yi said:

Awesome 5.6.1 worked!

Hi John Yi,

Can you help to tell me which steps you’ve done from your side to see it is working for you? Please try with New browser as well on our UAT site: demoaut.katalon.com

Please also help to send me your used prefs as well:
Windows
config\.metadata\.plugins\org.eclipse.core.runtime\.settings\com.kms.katalon.composer.webui.objectspy.prefs

macOS
/Applications/Katalon Studio.app/Contents/MacOS/config/.metadata/.plugins/org.eclipse.core.runtime/.settings/com.kms.katalon.composer.webui.objectspy.prefs

steps

1. removed 5.6.0

2. click on the link that Liam B above provided http://download.katalon.com/5.6.1/Katalon\_Studio\_Windows_64-5.6.1.zip

3. extract the zip file to any folder

4. went to the directory Katalon_Studio_Windows_64-5.6.1 and double click on katalon.exe

5. enter my credentials

6. click on “Record web” icon

7. entered my URL to test with

8. selected chrome icon

9. witness the fix, I was able to record my steps in chrome

I wasn’t able to find config\.metadata\.plugins\org.eclipse.core.runtime\.settings\com.kms.katalon.composer.webui.objectspy.prefs

look at ss below

2018-08-20_17-05-55.jpg