Problems to Playback a recorded test case


#1

Hi everybody,

I recorded a test case and I tryed playback it and I also playback the teste case sample “TC1_Verify Successful Login”. But the browser didn’t appear. My Katalon Studion version is “Katalon_Studio_Windows_64-5.8.6” - Version: 5.8.6 - Build: 1.

I put the image of execution and the .log file.

PS: I’ve configured the proxy and I checked for update and I’ve got up-to-date.


Test Case that I’ve recorded.


Test Case TC1_Verify Successful Login (Sample).

Issue_playback_Katalon Studio.PNG

.log

Issue_playback_Katalon Studio - Sample test case - TC1_Verify Successful Login.PNG


#2

hmmm the log file is throwing me off…Is this the first time you used Katalon? I would try to do a reinstall potentially. Just a few verification, did you save your project? Did you choose your default browser?


#3

B L said:

hmmm the log file is throwing me off…Is this the first time you used Katalon? I would try to do a reinstall potentially. Just a few verification, did you save your project? Did you choose your default browser?

Hi @B L.

Is this the first time you used Katalon? **Yeap. This is my first time.
**I would try to do a reinstall potentially. I only unzip it and lauch it from …\Katalon_Studio_Windows_64-5.8.6\katalon.exe - at Windows 10.
Just a few verification, did you save your project? **yeap, I did.
**Did you choose your default browser? **Yeap. I used in Chrome Version 70.0.3538.102 (64 bits) and Firefox 58.0.2 (64-bit). But unfortunately in both of them I didn’t success in running (playback).
**
Thanks for your questions and I hope these answers can clarify you to help me =).


#4

the two things I would try next are these:
- attempt to run katalon as administrator
- select script mode at the bottom and replace your login with this:
WebUI.navigateToUrl(‘YOURURLHERE’)

and put your url in there. Then attempt from the top next to the green run arrow click the dropdown arrow and select your browser there. See if that works. if it’s still not opening after admin and changing to not using the global variable, I’d have to think of something else. However this would be my first few steps to trouble shoot this.


#5

Hi @B L

I did your suggestion. But I didn’t work.

When I accessed the preferences I got this warning below.

So, I’ve tried change Installed JREs for my workstation, like below, but didn’t work too.

Location of Log file: C:\Katalon_Studio_Windows_64-5.8.6\config\.metadata\.log

In log file attached has errors, that’s occurs after close Katalon Studio.

Katalon_Preferences_1.PNG

Katalon_Preferences_2.PNG

ERRORs_Katalon Studio - 2018_11_28.log


#6

Hi people, someone could help me, please? :blush:


#7

Hi @Rodrigo_Melo

Let’s take a huge step back. In your first post there is a screenshot showing that you have an error but we can’t see what the error is. Change your Log Viewer to display a list of logs (not a tree) and run that test again. THEN post your error(s) here.

Also, create a new test, go to the Script panel and make sure it contains EXACTLY this:

import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI

WebUI.navigateToUrl("www.google.com")

If this simple test doesn’t work at all, post any errors you see in the console/log viewer.


#8

Ok @Russ_Thomas. Let’s do it.

I’ve tried to do what you’ve asked me. Please, see the files attacheds. I hope you can discover the problem’s cause. I guess that’s my Java compiler configuration or something like that.

ERRORs_Katalon Studion - 2018_12_17 - AfterRunASimpleTest.log (172.2 KB)
ERRORs_Katalon Studion - 2018_12_17 - AfterRunMyTest.log (79.7 KB)


#9

No errors in the console? Extraordinary.

The idea Rodrigo, was to get a report from Katalon when trying to do something extremely simple and basic. Now we sit back and wait for @devalex88 / @Vinh_Nguyen et al take a look at those logs (because I’m stumped).


#10

@Rodrigo_Melo,

Could you please click on the tree icon before executing the test? The JRE configuration should not be changed - I would suggest starting over with a fresh copy of Katalon Studio 5.9.1.


#11

Hi @devalex88 I clicked on the tree icon before executing these tests. Please see the pictures, I had the same behavior.

I will try use a fresh copy of Katalon Studio 5.9.1 without change JRE configuration, after that I’m going to answer here.

See ya and Merry Christmas for all.


#12

Just wonder - is it a company PC? I’ve encountered occasions where Firewall prevented Selenium from starting new sessions.


#13

Can you do it again but this time with the Console tab opened?


#14

Hello @devalex88,

Happy New Year!

So, I’ve tried to run again, but the Console tab didn’t give me anything. Then, I downloaded the newest version of Katalon Studion (5.10.1) and I have the same behavior.

I use selenium with eclipse for other projects and it’s works. But with Katalon, I don’t know what’s the cause of this problem. I hope you can help.

PS: I didn’t change the JRE configuration in this fresh copy.

Regards,

Rodrigo Melo.


#15

Thank you for your patience. Could you please create a test case with the following content

System.out.println("Hello")

then run it and check the Console tab?


#16

Hi All.
I am facing exactly the same issue reported by Rodrigo_Melo.
After installing Katolon, everything was working fine, I could execute the sample code and my own code, in mobile and web testing.
Now, I cannot execute them, even the sample code. Katalon does not launch the tests for mobile and web testing.
For recording, mobile and web, is working fine.

Setup:
Katalon_Studio_Windows_64-5.10.1
Windows 10 64 bits


#17

Hi @devalex88, sorry my late and thanks for help. That’s the print of my Console tab and Log Viewer tab.

PS: I’m using “Katalon_Studio_Windows_64-5.10.1”.


#18

Hello people, could anyone help me with the problem above?


#19

I downloded the new version of Katalon and the issue is still happening. Katalon does not launch the tests for mobile and web testing. I cannot playback a recorded test case.
Katalon Version: 6.0.4
Build: 7