Object spy shortcuts for French keyboard

Hi,

I’m working with a French keyboard and when I “spy web”, I’m not able to capture objects with the command Alt + ~. I would like to change this shortcut because, with a French keyboard, printing Alt + ~ is not an easy combination. Printing a ~ requires Alt gr and a space. Where can I configure that? For instance it could be Alt + K…

Thank you,

Zoé

Hello Zoé,
Default keys can be changed under Window, Katalon Studio Preferences, then Katalon, Object Spy.

2 Likes

Hi, with the new version (4.6) this is now possible with Google Chrome. Thank you Katalon Team! :slight_smile:

Hi there,
Unfortunate these keys can’t be changed. Can you try to change your current keyword settings from French to English and use that keyboard setting for this key combinations?
https://support.microsoft.com/en-us/help/258824/how-to-change-your-keyboard-layout
http://www.windowscentral.com/how-change-your-keyboard-layout-windows-10
Thanks.

I am using a UK keyboard but the Alt +` keys do not seem to capture the object. The web object is highlighted with a red border but it will not change to green. D you know what I am doing wrong?

@Linda Vigor said:
I am using a UK keyboard but the Alt +` keys do not seem to capture the object. The web object is highlighted with a red border but it will not change to green. D you know what I am doing wrong?

Hi Linda
did you manage to resolve this please? I am also unable to capture any objects with Alt + ~. If I use web recorder the same objects will be captured however.

@Dan Bown said:

@Linda Vigor said:
I am using a UK keyboard but the Alt +` keys do not seem to capture the object. The web object is highlighted with a red border but it will not change to green. D you know what I am doing wrong?

Hi Linda
did you manage to resolve this please? I am also unable to capture any objects with Alt + ~. If I use web recorder the same objects will be captured however.

I am using IE11 for Alt + ~ or Chome for Alt + '. Neither browser works

Have you tried to change its hotkeys? http://docs.katalon.com/display/KD/Object+Spy+Preferences

1 Like

Hi!
I have tried to edit the keys I shall use, but apparently it is not possible:-(
Can you please help?
Thanks in advance

Hi Mariana,

I had the same problem with my PT keyboard, to change them click on the Capture Object text box (just to highlight) then click for example Alt+z

PLS have a look at this:
https://forum.katalon.com/discussion/6046/spy-web-capturing-by-alt-backquote-fails-due-to-dependency-on-language-keyboard-settings-of-os

There you will find my view of this issue:

ALT+Backquote is dependent on the Keybord type. Spy Web should add an reliable alternative keystroke which emits KeyCode common to all types of Keyboards. I would suggest ALT+Comma(,)

|Keyboard |Keystroke |KeyCode emitted|
|US |ALT+Comma(,) |18,44 |
|JP |ALT+Comma(,) |18,44 |

Vinh Nguyen said:

Have you tried to change its hotkeys? http://docs.katalon.com/display/KD/Object+Spy+Preferences

Vinh,

I would disagree with the idea of asking users to change the keyboard setting for the Spy when he/she feels like to try Alt+` stroke. I would never do this. I think the Spy should accept other keystroke (e.g., Alt+, ) for capturing.

Please have a look. again, at my study:

I use a French keyboard too. I changed the hotkey in the Katalon Studio Prefrences and switched to ‘Alt+a’.
It works like a charm in both Chrome and Firefox.

Katalon Studio 5.4.1
Chrome 66.0.3359.139
Firefox 59.0.3

1 Like

Philippe,

Thank you for information. I tried changing the hotkey to switch to ‘Alt+a’, and success. This let me recognize my misunderstanding.

Hello,

To capture object using French keyboard, use (Alt+ù).

Alt+ù, it doesn’t work.

You have to change in Katalon Studio Préférences.

I am using a German keyboard. While we can change the shortcut key combination for capturing a highlighted DOM element, it is not possible to change the shortcut for inspecting the DOM tree. There is not alternative to inspecting the DOM tree besides the shortcut alt+`…
I tried changing the keyboard language preferences to US and UK, but it does not work. I think a German standard keyboard is unable to emit the signature needed for the DOM tree shortcut.

Please make it possible to change the shortcut for inspecting the DOM tree, similar to the already existing option of changing shortcut for capturing a specific element. Thank you!

1 Like

Yes, Please make it possible for the next version of Katalon.
it’s not possible in the 6.1.0 version neither 6.2.0