Not working with frame

I am trying to test sign up link and new frame will open when i click on it. I observe that test getting fail when it switch to frame. Please check it and fix this issue.


It looks I have a similar problem. Running a simple web test with google maps route planning. Get the error message

[ERROR] Blocked a frame with origin “” from accessing a cross-origin frame.

Any help would be very welcome

Hey guys,

I have logged this issue for the development team to investigate. We will update once we found the root cause.

However, Katalon Studio does support Record and Playback feature and works well with iFrame and Shadow DOM. It’s completely free! Download here.

Prefer to this guide how to export and import scripts into Katalon Studio.
Tutorial on Handling iFrame.

Thanks for letting us know and using Katalon Automation Recorder,


I’m confused as to why this issue is closed, I have tried using both the Record and Playback feature as well as the Automation Recorder and continuously run into issues where the test records the iframe objects but then they don’t work in playback.


Could you please give us a sample. Because different web pages behave differently, that will help a lot in reproducing the issue.


I am fairly new to Katalon. I am having trouble getting out from the Frame in salesforce application.
First I used selectFrame index=1 then complete fields within that frame. Then I tried to go to another frame and used selectFrame index=0. It tries to find that within the index=1 Frame and throws timeout error.

Could someone please help me get out of the index=1 frame?

Thanks in Advance!