License Activation API Failure

Uncertain where to place this.

Starting Friday morning (August 7), a Katalon Jenkins job I have started failing to start. Prior to this, I made no changes to the job or to the test suite it was deploying. I was wondering if, perhaps, there’s been a change to the API for online activation.

I am using a paid-for license for Katalon 7.2.1.

I am unaware of the license expiring or if even there was a change in how we were using the license, but the response I get suggests a problem with that. (I don’t have immediate access to check this, but I will get it. I am, however, doubtful that I will find an issue.) However, I appear to have been getting the same response earlier, but it wasn’t causing a problem then. Now, it terminates the test.

Previously, I would see this during the start-up:
[2020-08-06T05:08:38.990] Activating…
[2020-08-06T05:08:38.997] Start activating offline…
[2020-08-06T05:08:38.997] Search for valid offline licenses in folder: /var/lib/jenkins/.katalon/license
[2020-08-06T05:08:39.009] The number of valid offline licenses: 0
[2020-08-06T05:08:39.009] Offline activation failed.
[2020-08-06T05:08:39.009] Start activating online…
[2020-08-06T05:08:50.779] Machine quota exceeded.
[2020-08-06T05:08:50.782] Delete folder: bin
. . .

Despite the “Machine quota exceeded” it would go on to run and perform the test. I did, in fact, have a license for the machine I was using.

On August 7, however, this changed to:
[2020-08-07T05:08:08.962] Activating…
[2020-08-07T05:08:08.962] Start activating offline…
[2020-08-07T05:08:08.962] Search for valid offline licenses in folder: /var/lib/jenkins/.katalon/license
[2020-08-07T05:08:08.971] The number of valid offline licenses: 0
[2020-08-07T05:08:08.971] Offline activation failed.
[2020-08-07T05:08:08.971] Start activating online…
[2020-08-07T05:08:11.446] Katalon TestOps: Unexpected response, URL:[machine-key]&ksVersion=7.2.1&email&sessionId=[session-id]&hostname=jenkins2&package=ENGINE, Status: 400, Response: {“timestamp”:“2020-08-07T09:08:11.410+0000”,“status”:400,“error”:“Bad Request”,“message”:“Machine quota exceeded.”,“trace”:"com.katalon.kit.exception.KaBadRequestException: Machine quota exceeded.\n\tat

. . . followed by a stacktrace. The job would then terminate and none of the tests would run.

i am facing the same issue. I have raised it in a support ticket but can someone please get back to us.
I really want to know whats happening.


I should provide this additional information:

  1. I may have misplaced this. This is not happening in Katalon Studio, but in Jenkins.
  2. I believe Jenkins is using my Runtime Engine license.
  3. I have an api key that Jenkins uses, but I am unable (from my admin view of to confirm whether this api key is linked to the Runtime Engine license. I was merely provided this api key by an employee who set it up just prior to retiring. I do know, however, that the key appeared to work prior to this.

Hi @hstine

The error is saying that the machine quota exceeded, which in your case means another machine is using the associated KRE license. Please contact with someone who can check the status of the KRE licenses (on TestOps page of your organization) to see if the KRE license is binding to your machine ID or not. If it binds to another machine, the person viewing the status can manually remove the license from a machine, which would enable other machines to use the license.

Your machine ID can be easily retrieved if you re-activate Katalon Studio, and go to Offline Activation (don’t actually activate offline, just to see your machine ID).

Let me know if that helps !

Hello @ThanhTo , what about when only one machine is using the key and they still having the issue.



In that case please provide more information, like screenshots of TestOps page that indicates that a KRE license is currently not in use, your machine ID, and wether or not you have activated an offline license before.

@ThanhTo , it is an online license that i have and only one license which i use.

Very much appreciate your help. It appears to me that another machine was registered, as you suggested. I was able to solve it without too much trouble. To make it concrete for future sufferers, I followed the below steps:

  1. Logged onto Jenkins and navigated to [Katalon Job]->Selected the most recent build attempt from the lower-left->Console Output
  2. In the output, I located the following line: “[Date Time Group] INFO: Machine ID: [Machine ID]”. I then took note of the id string that was displayed.
  3. Logged into and navigated to Licenses->Katalon Runtime Engine
  4. Looked at the “Registered Machines” section and took note of the Machine ID displayed there.
  5. I learned that the Machine ID from Step 4 differed from the Machine ID from Step 2.
  6. To resolve this, I clicked the trashcan icon next to the Machine ID from Step 4 to “Remove Machine”. Then I ran my Katalon Jenkins job again, which functioned to register the Jenkins server with my Katalon account. After this, it worked.
1 Like

If your server is behind an internet proxy you may need to add an additional command line flag indicating the address and credentials required to communicate through the proxy. Note however that this may not be necessary if either the http_proxy or all_proxy environment variable is defined (these are read and used by our server products when available).

If you do need to specify a proxy server explicitly you can do so using the --proxy command line parameter. For example:

$ sudo rstudio-server license-manager --proxy= activate

$ sudo /opt/shiny-server/bin/license-manager --proxy= activate
Proxy settings can include a host-name, port, and username/password if necessary. The following are all valid proxy configurations:
If the port is not specified, the license manager will default to using port 1080.