KRE version 9.3 linux setup - error in KRE

Dear Katalon Community,

My name is Sylvia Astrida from PT. Indocyber Global Technology in Jakarta Indonesia

We are trying to setup the Katalon KRE linux
A. Server linux with GUI,
1. KRE version 9.3 Linux ubuntu and redhat, running katalonc on Chrome
and FireFox has an error

       **java.lang.NullPointerException: Cannot invoke **
**      "java.lang.Exception.getMessage()" because the return value of **
**      "com.kms.katalon.feature.TestOpsMessageError.getException()" is null**
     2. KRE version 8.8 stable version we can running the script, only firefox 
         has a successfull, for the chrome still an error (is it because the 
         difference of chromedriver ? on KRE Chrome driver support 1.14 and 
         Chrome driver 1.22) 
B. Server linux without GUI using the headless script 
     1. KRE version 8.8 stable, the browser firefox has succesfull but chrome 
          still  has an error 
          ChromeDriver was started successfully.
         **2024-02-26 17:42:34.463 ERROR **
**         c.k.k.core.keyword.internal.KeywordMain  - ❌ Unable to open browser **
**         with url: '' (Root cause: **
**         com.kms.katalon.core.exception.StepFailedException: Unable to open **
**          browser with url: ''**
**          at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:64)**
**	at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:26)**
**	at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.openBrowser(OpenBrowserKeyword.groovy:81)**
**	at com.kms.katalon.core.webui.keyword.builtin.OpenBrowserKeyword.execute(OpenBrowserKeyword.groovy:67)**
**	at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:74)**
**	at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.openBrowser(WebUiBuiltInKeywords.groovy:64)**
**	at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$ Source)**
**	at**
**	at**
**	at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(**
**	at com.kms.katalon.core.main.TestCaseExecutor.runScript(**
**	at com.kms.katalon.core.main.TestCaseExecutor.doExecute(**
**	at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(**
**	at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(**
**	at com.kms.katalon.core.main.TestCaseExecutor.execute(**
**	at com.kms.katalon.core.common.CommonExecutor.accessTestCaseMainPhase(**
**	at com.kms.katalon.core.main.TestSuiteExecutor.accessTestSuiteMainPhase(**
**	at com.kms.katalon.core.main.TestSuiteExecutor.execute(**
**	at com.kms.katalon.core.main.TestCaseMain.startTestSuite(**
**	at com.kms.katalon.core.main.TestCaseMain$startTestSuite$ Source)**
**	at**
**Caused by: org.openqa.selenium.WebDriverException: unknown error: Chrome failed to start: exited abnormally.**
**  (unknown error: DevToolsActivePort file doesn't exist)**
**  (The process started from chrome location /opt/google/chrome/google-chrome is no longer running, so ChromeDriver is assuming that Chrome has crashed.)**

Please your advice asap

Many Thanks for your assistance

Best regards

1 Like

You are not alone. I would like to invite you to the club of the frustrateds.

Katalon mentioned that they will release a hot fix by the end of Feb.

is there any update on this?

I solved this by adding this line in my case azure-devops-extension-samples/azure-pipelines-linux.yml at master · katalon-studio-samples/azure-devops-extension-samples · GitHub

Hi katalon

Sorry for the late reply

Yes it’s solved thanks but we had been used 8.6.8 version, if we had been choose the 9.3.1 we had an error, run on server

Best Regards
Sylvia Astrida