Katalon 'Web Recorder' NOT working in Chrome Private Mode

KSE 8.2.0, 208
Windows 10, Enterprise, 64 bit
Chrome: Version 97.0.4692.71 (Official Build) (64-bit)

Our company requires we run our automation tests in Chrome Private Mode. Our QA team (mostly non-automation engineers), makes heavy use of the ‘Katalon Record Web’ feature. The Katalon ‘Web Recorder’ starts in Chrome Private Mode but no recording takes place when clicking onto objects.
Our only work-around is to rename the ‘com.kms.katalon.core.webui.chrome.properties’ file before doing any recording. Does anyone know if there is another work-around. I wonder if this would fall under a Katalon feature change request?

Katalon
	--Project
		--Settings
			--Desired Capabilties
				--Web UI
					--Chrome
						--|Name |Type | Value
						   args  List   --incognito 

com.kms.katalon.core.webui.chrome.properties:
{"CHROME_DRIVER":{"args":["--incognito"]}}

Hi @ThanhTo, @duyluong have either of you experienced this issue? Is it by design?

@Dave_Evers,

Currently, Katalon Record Utility will use the default Chrome desired capabilities in Project Settings in every new recording session.

You can create a custom desired capabilities with the incognito mode then use it for daily runnings and keep blank desired capabilities in the default Chrome desired capabilities for recording

Hi @duyluong,

Thanks for the quick reply.

I created a Custom Desired Capability record named “Chrome-Incognito” which works when I pick it from the Run button drop-down.

Is there a way to set the ‘Custom Desired Capability’ as the default, so it does not have be picked each time? I checked under ‘Default execution’ but it is not listed.

Also can I use the ‘Custom Desired Capability’ record to run Test Suite Collections?
If I can I am not seeing how that can be done.

Cheers,
Dave